Bug 1028793 - systemctl start vdsmd blocks if dns server unreachable
systemctl start vdsmd blocks if dns server unreachable
Status: CLOSED NOTABUG
Product: oVirt
Classification: Community
Component: vdsm (Show other bugs)
3.3
Unspecified Unspecified
medium Severity low
: ---
: 3.4.0
Assigned To: Yaniv Bronhaim
yeylon@redhat.com
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-10 14:47 EST by Petr Beňas
Modified: 2016-04-18 02:46 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-18 05:09:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Beňas 2013-11-10 14:47:39 EST
Description of problem:
Start of vdsmd with reconfiguration blocks on hostname -f. 

Version-Release number of selected component (if applicable):
vdsm-4.13.0-110.git8893dc5.fc19.x86_64

How reproducible:
100%

Steps to Reproduce:
1. disconnect ethernet or make dns server unreachable so `hostname -f` blocks
2. touch ovirtmgmt ifcfg file or qemu.conf
3. systemctl start vdsmd
4. systemctl status vdsmd

Actual results:
Start of the service is blocked on hostame -f.
   CGroup: name=systemd:/system/vdsmd.service
           └─control
             ├─28451 /bin/sh /usr/libexec/vdsm/vdsmd_init_common.sh --pre-start
             ├─28475 /bin/bash /usr/libexec/vdsm/vdsm-gencerts.sh --check
             └─28477 hostname -f

Expected results:
Service starts even if hostname -f blocks. 

Additional info:
Comment 2 Yaniv Bronhaim 2014-02-17 02:59:30 EST
it does not block. after few seconds you get "hostname: Host name lookup failure" and the startup moves on. the actual results are as expected.

can you please check again , maybe i missed something
otherwise I'll close as NOTABUG


my output:
 ~]# service vdsmd restart
Shutting down vdsm daemon: 
vdsm watchdog stop                                         [  OK  ]
vdsm: not running                                          [FAILED]
vdsm: Running run_final_hooks
vdsm stop                                                  [  OK  ]
initctl: Job is already running: libvirtd
vdsm: Running mkdirs
vdsm: Running configure_coredump
vdsm: Running run_init_hooks
vdsm: Running gencerts
hostname: Host name lookup failure     <---- the failure
vdsm: Running check_is_configured
libvirt is already configured for vdsm
sanlock service is already configured
vdsm: Running validate_configuration
SUCCESS: ssl configured to true. No conflicts
vdsm: Running prepare_transient_repository
vdsm: Running syslog_available
vdsm: Running nwfilter
vdsm: Running dummybr
vdsm: Running load_needed_modules
vdsm: Running tune_system
vdsm: Running test_space
vdsm: Running test_lo
vdsm: Running restore_nets
vdsm: Running unified_network_persistence_upgrade
vdsm: Running upgrade_300_nets
Starting up vdsm daemon: 
vdsm start                                                 [  OK  ]
Comment 3 Petr Beňas 2014-02-17 04:38:39 EST
Which version did you test in? Is it possible it got fixed meanwhile? I remember blocking for minutes, will retest in the same version you did.
Comment 4 Yaniv Bronhaim 2014-02-17 04:50:39 EST
btw, the host cannot join to cluster with the error "Host *** installation in progress . Cannot validate host name settings, reason: cannot resolve own name '***'."
even-though vdsm is up. also, this is the expected behavior
Comment 5 Yaniv Bronhaim 2014-02-17 08:49:55 EST
I checked on 3.13 and 3.14 , both works for me after a short delay (hostname's timeout). please recheck and close if works
Comment 6 Petr Beňas 2014-02-17 11:02:32 EST
Also unable to reproduce with blocked DNS in 3.13, feel free to close.

Note You need to log in before you can comment on or make changes to this bug.