Bug 1028799 - SDDM ignores translation
SDDM ignores translation
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: sddm (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Bříza
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-10 15:50 EST by František Zatloukal
Modified: 2014-07-01 10:17 EDT (History)
7 users (show)

See Also:
Fixed In Version: sddm-0.2.0-0.31.20140627gitf49c2c79
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-01 10:17:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description František Zatloukal 2013-11-10 15:50:16 EST
Description of problem:
sddm just ignores translation. Problem since update to new (Heisenbug) theme.

Version-Release number of selected component (if applicable):
0.2.0-0.20.20130914git50ca5b20.fc21

How reproducible:
Always

Steps to Reproduce:
1. Install Fedora with language different than English
2. Launch sddm

Actual results:
Everything is in English.

Expected results:
sddm should detect actually used language and use proper language file for that.

Additional info:
Tested with czech localization. Since I've added czech translation and it used to work earlier.
Comment 1 František Zatloukal 2013-11-10 15:52:04 EST
Ignore "since" in the last sentence ...
Comment 2 Martin Bříza 2013-11-11 07:56:34 EST
Thanks, it's a problem of the default Fedora theme I think, it's on my list.
Comment 3 Fedora Update System 2013-11-25 12:39:57 EST
sddm-0.2.0-0.21.20131125git7a008602.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/sddm-0.2.0-0.21.20131125git7a008602.fc20
Comment 4 Fedora Update System 2013-11-26 12:59:28 EST
Package sddm-0.2.0-0.22.20131125git7a008602.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing sddm-0.2.0-0.22.20131125git7a008602.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-22158/sddm-0.2.0-0.22.20131125git7a008602.fc20
then log in and leave karma (feedback).
Comment 5 Martin Bříza 2014-07-01 10:17:43 EDT
Fixed by sddm-0.2.0-0.31.20140627gitf49c2c79

Note You need to log in before you can comment on or make changes to this bug.