This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1028854 - [abrt] git-cola-1.8.5-1.fc19: view.py:550:_update_callback:UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 17: ordinal not in range(128)
[abrt] git-cola-1.8.5-1.fc19: view.py:550:_update_callback:UnicodeDecodeError...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: git-cola (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Christopher Meng
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:28eb4235c5d101b947da113e04c...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-10 22:59 EST by Guillaume Poirier-Morency
Modified: 2013-11-23 23:04 EST (History)
3 users (show)

See Also:
Fixed In Version: git-cola-1.9.1-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-23 14:38:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (669 bytes, text/plain)
2013-11-10 22:59 EST, Guillaume Poirier-Morency
no flags Details
File: environ (3.28 KB, text/plain)
2013-11-10 22:59 EST, Guillaume Poirier-Morency
no flags Details

  None (edit)
Description Guillaume Poirier-Morency 2013-11-10 22:59:07 EST
Version-Release number of selected component:
git-cola-1.8.5-1.fc19

Additional info:
reporter:       libreport-2.1.9
cmdline:        /usr/bin/python /usr/bin/git-cola
executable:     /usr/bin/git-cola
kernel:         3.11.6-201.fc19.x86_64
runlevel:       N 5
type:           Python
uid:            1001

Truncated backtrace:
view.py:550:_update_callback:UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 17: ordinal not in range(128)

Traceback (most recent call last):
  File "/usr/share/git-cola/lib/cola/main/view.py", line 550, in _update_callback
    title = '%s: %s (%s)' % (self.model.project, branch, self.model.git.worktree())
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 17: ordinal not in range(128)

Local variables in innermost frame:
msg: u'Repository: /home/guillaume/D\xe9p\xf4ts/budjhete\nBranch: 2.2/develop'
self: <cola.main.view.MainView object at 0x10b27a0>
curdir: u'/home/guillaume/D\xe9p\xf4ts/budjhete'
branch: u'2.2/develop'
Comment 1 Guillaume Poirier-Morency 2013-11-10 22:59:14 EST
Created attachment 822258 [details]
File: backtrace
Comment 2 Guillaume Poirier-Morency 2013-11-10 22:59:18 EST
Created attachment 822259 [details]
File: environ
Comment 3 David Aguilar 2013-11-11 22:54:06 EST
This may have already been fixed in v1.9.1.  Can you please try cloning the git repository and seeing if the bug still exists there?

You won't need to build or install anything, just run

git clone git://github.com/git-cola/git-cola.git ~/src/git-cola
~/src/git-cola

I tried replicating this same utf-8 directory structure and it seems to be working.  There was a big unicode refactor between v1.8.5 and the latest.

v1.9.2 will be released before the end of the year as well.
Comment 4 David Aguilar 2013-11-11 22:54:51 EST
Should have said, "~/src/git-cola/bin/git-cola"
Comment 5 Christopher Meng 2013-11-11 22:57:20 EST
(In reply to davvid from comment #4)
> Should have said, "~/src/git-cola/bin/git-cola"

I will push an update of git-cola now. It's not good for users to use git snapshot.

Sorry, but I haven't received any new release notification and forgot this in the past.
Comment 6 Fedora Update System 2013-11-11 23:13:09 EST
git-cola-1.9.1-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/git-cola-1.9.1-1.fc18
Comment 7 Fedora Update System 2013-11-11 23:13:59 EST
git-cola-1.9.1-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/git-cola-1.9.1-1.fc19
Comment 8 Fedora Update System 2013-11-11 23:23:27 EST
git-cola-1.9.1-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/git-cola-1.9.1-1.fc20
Comment 9 Fedora Update System 2013-11-12 21:06:26 EST
Package git-cola-1.9.1-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing git-cola-1.9.1-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-21150/git-cola-1.9.1-1.fc19
then log in and leave karma (feedback).
Comment 10 Kevin Kofler 2013-11-12 21:12:07 EST
> Sorry, but I haven't received any new release notification and forgot this in
> the past.

Grrr, the HTML changed on us AGAIN, breaking the Upstream Release Monitoring regex again. GitHub is really a PITA. (We need some standard way to get releases from GitHub projects, right now we have different hacks for different GitHub-hosted projects, and all of them can break at any time.) I'm fixing the regex.
Comment 11 Fedora Update System 2013-11-23 14:38:27 EST
git-cola-1.9.1-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2013-11-23 14:46:29 EST
git-cola-1.9.1-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2013-11-23 23:04:21 EST
git-cola-1.9.1-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.