Bug 10289 - linuxconf causes sendmail to discard most bounced mail notifications
Summary: linuxconf causes sendmail to discard most bounced mail notifications
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: linuxconf   
(Show other bugs)
Version: 6.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-03-21 22:39 UTC by freemyer
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:47:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description freemyer 2000-03-21 22:39:40 UTC
If one sends an e-mail to an invalid address (i.e. invalid1234@aol.com)
then the rejection notice (i.e. User Unknown) is often returned to
sendmail with the 'return-path' blank.

Normally sendmail delivers this notice to the originator of the original e-
mail.

If linuxconf is used to generate the sendmail.cf, then about 80% of the
time the notification is discarded with a error message placed in the
maillog file.  (I assume that for the other 20% the return-path is
provided.  I know that the problem happens for all mail bounced from AOL,
but from lots of other places as well.)

I suspect the check_mail rule is the culprit, but I am not sure.

Work-around: Use /etc/sendmail.mc file and the m4 macros to generate your
sendmail.cf file.

Comment 1 Brent Fox 2002-06-05 16:15:37 UTC
Closing because we don't ship linuxconf anymore

Comment 2 Red Hat Bugzilla 2006-02-21 18:47:38 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.