Bug 1028926 - eclipse-jgit: Bundled apache-common-compress
eclipse-jgit: Bundled apache-common-compress
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: eclipse-jgit (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Sami Wagiaalla
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-11 04:14 EST by Mikolaj Izdebski
Modified: 2016-06-07 18:46 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-29 15:31:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mikolaj Izdebski 2013-11-11 04:14:23 EST
Description of problem:
Package eclipse-jgit bundles apache-common-compress library, version 1.5.0.

Version-Release number of selected component (if applicable):
3.1.0

Additional info:
Path to bundled library is:
/usr/share/eclipse/dropins/jgit/eclipse/plugins/org.apache.commons.compress_1.5.0.jar
Comment 1 Roland Grunberg 2013-11-12 15:55:56 EST
I see /usr/share/eclipse/dropins/jgit/eclipse/plugins/commons-compress.jar (symlink) and /usr/share/eclipse/dropins/jgit/eclipse/plugins/org.apache.commons.compress_1.5.0.jar so perhaps the latter can simply be removed. Also, I noticed that jgit requires args4j but the symlink is owned by eclipse-jgit.
Comment 2 Krzysztof Daniel 2013-11-13 02:21:02 EST
The args4j part is a tricky one. Look at the patch fix_jgit_sh.patch, line 8. jgit is a regular java package, and it references args4j directly. As long as eclipse-jgit requires jgit, or eclipse-jgit requires args4j, everything is fine.
Comment 3 Gerard Ryan 2014-02-17 06:46:20 EST
I was just about to open a new bug about the args4j issue until I saw it mentioned in this one. I was testing rawhide at the weekend, and the args4j symlink was broken because the args4j package hadn't been installed as a required dependency.
Comment 4 Alexander Kurtakov 2014-05-29 15:31:48 EDT
I fixed this bug on Mar 31 2014

Note You need to log in before you can comment on or make changes to this bug.