Bug 102894 - ContentItem.getPath includes the bundle
Summary: ContentItem.getPath includes the bundle
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise CMS
Classification: Retired
Component: other (Show other bugs)
(Show other bugs)
Version: nightly
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Archit Shah
QA Contact: Jon Orris
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 108447
TreeView+ depends on / blocked
 
Reported: 2003-08-22 13:43 UTC by Randy Graebner
Modified: 2007-04-18 16:57 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-10 21:01:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Randy Graebner 2003-08-22 13:43:02 UTC
Description of problem:
Calling ContentItem.getPath() includes the bundle in the path.  This gives us a
path similar to
/ccm/content/linfo/bref/fondation-carrefour/testpage-item/testpage-item when in
fact the URL is /ccm/content/linfo/bref/fondation-carrefour/testpage-item

Adding 
<code>col.addNotEqualsFilter(OBJECT_TYPE, ContentBundle.TYPE); </code>
to line 673 of ContentItem
would fix the problem for ContentItems but it would then not work for
ContentBundles.  And, since I do not know what the correct behavior is for a
ContentBundle, I figure I should refer this back to engineering.

This is a problem because ContentPage.getSearchURLStub uses the call to getPath
and thus returns an invalid URL.  The same method also does not work because 
<code>return URL.there(sectionPath + getPath(), null).toString();</code>
should actually be
<code>return URL.there(sectionPath + "/" + getPath(), null).toString();</code>


Version-Release number of selected component (if applicable):
6.0

How reproducible:
Always

Steps to Reproduce:
1.  Call ContentPage.getSearchURLStub and you will see both problems.
2.
3.
    
Actual results:
/ccm/contentlinfo/bref/fondation-carrefour/testpage-item/testpage-item

Expected results:
/ccm/content/linfo/bref/fondation-carrefour/testpage-item

Additional info:


Note You need to log in before you can comment on or make changes to this bug.