Bug 1028957 - resource-agents-3.9.2-21.el6_4.8.x86_64 uses incorrect heartbeat path
resource-agents-3.9.2-21.el6_4.8.x86_64 uses incorrect heartbeat path
Status: CLOSED DUPLICATE of bug 1028127
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: resource-agents (Show other bugs)
6.4
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: David Vossel
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-11 05:52 EST by Christoph Galuschka
Modified: 2013-11-14 05:43 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-14 05:43:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christoph Galuschka 2013-11-11 05:52:25 EST
Description of problem:
resource-agents-3.9.2-21.el6_4.8.x86_64 alters the path for the heartbeat binary to /usr/libexec/heartbeat even though the actual path for 64bit heartbeat is /usr/lib64/heartbeat. This makes the heartbeat init script exit without warning. 

Version-Release number of selected component (if applicable):
resource-agents-3.9.2-21.el6_4.8.x86_64

How reproducible:
always

Steps to Reproduce:
1. Install heartbeat from EPEL.
2. Update all packages to latest.
3. run 'service heartbeat start' - the script just exits.

Actual results:
heartbeat does not get started.

Expected results:
heartbeat starts

Additional info:
This seems to be the cause:
-: ${HA_BIN:=/usr/lib64/heartbeat}
+: ${HA_BIN:=/usr/libexec/heartbeat}
Comment 2 David Vossel 2013-11-13 21:48:04 EST
(In reply to Christoph Galuschka from comment #0)
> Description of problem:
> resource-agents-3.9.2-21.el6_4.8.x86_64 alters the path for the heartbeat
> binary to /usr/libexec/heartbeat even though the actual path for 64bit
> heartbeat is /usr/lib64/heartbeat. This makes the heartbeat init script exit
> without warning. 

This is not a resource-agent package problem.  The heartbeat package should not be tightly coupled to the resource-agents in this way.
Comment 3 Christoph Galuschka 2013-11-14 01:55:02 EST
OK.

Should I post the bug against EPEL then?
Comment 4 Fabio Massimo Di Nitto 2013-11-14 05:43:36 EST

*** This bug has been marked as a duplicate of bug 1028127 ***

Note You need to log in before you can comment on or make changes to this bug.