Bug 102896 - Problems with Trident XP4m32 videocard on Toshiba Tecra M1
Problems with Trident XP4m32 videocard on Toshiba Tecra M1
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-22 09:58 EDT by alex.breeze
Modified: 2007-04-18 12:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-22 13:33:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description alex.breeze 2003-08-22 09:58:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
The (new) Trident XP4m32 video card in the Toshiba Tecra M1 isn't recognised in
installation and is installed as a generic VESA with 16-bit colour. The colours
don't display properly in this mode so the graphic install is virtually
unreadable and a text install has to be done. After installation, it turns out
that VESA does work in 8-bit pseudocolour mode but not in the default 16-bit or
in 24-bit mode. So what's the problem with that? Well, no truecolour, no
acceleration so a high-end laptop's capabilities rather wasted. Then tried
playing with the options for the trident driver (explicitly identifying it as a
cyberbladeXPAi1 chipset -- which it isn't really, but that's the nearest that
the driver supports -- and giving its PCI address, in XF86Config). So far, only
using the ShadowFB (i.e. unaccelerated again) option can I get it to display at
all without locking up; it will now display 16- and 24-bit colour 'properly',
but no matter what I've tried to date (various resolutions etc.) the desktop is
4 times the size of the screen -- i.e., I only see the top left hand quarter.
This is frustrating. Do I have to wait for a new XFree86 trident driver release
before my M1 will be fully functional in Linux?

Version-Release number of selected component (if applicable):
XFree86-4.3.0-2

How reproducible:
Always

Steps to Reproduce:
1. Run graphical install
2. Try to read the mud
3. Give up and run text install
4. Set 8-bit for VESA; OK, can now see
4. Play around with XF86Config trident driver options

    

Actual Results:  So far, either (i) X crashes/hangs or (ii) if using ShadowFB
option, can only see 1/4 of desktop irrespective of resolution specified.

Additional info:
Comment 1 Mike A. Harris 2003-08-22 13:33:27 EDT
Your video hardware is not supported by XFree86 4.3.0, and not supported
by Red Hat Linux.  You may experiment with the "vesa", or "vga" drivers,
however neither are supported officially.  The "vga" driver gives very limited
graphics capability which is mostly useless on a modern desktop, while the
"vesa" driver may or may not provide various different resolution choices
at different color depths.  The "vesa" driver uses the card's own video
BIOS to set up video mode timings and is thus limited to whatever video
modes the BIOS has built in.  Since the "vesa" driver uses the BIOS, any
modes that do not work, are bugs in the BIOS and are fixable only by the
vendor via a BIOS update.  They are not fixable in XFree86, and as such
the vesa driver is provided unsupported, in hopes that it might work if
no other driver is available.  Another option, is to try the kernel
framebuffer driver, although it is not supported by us either, although
we provide it as-is for an extra option for those who wish to try it out
anyway.  The Framebuffer-HOWTO can be used to set this up if desired.

We will not be able to support this video hardware until XFree86 upstream
has added support for it in a stable new XFree86 release.  You may wish
to contact XFree86.org and/or Trident to inquire about when they expect
this hardware to be supported if you wish.

This isn't a bug, but rather just unsupported hardware, so closing as NOTABUG

Note You need to log in before you can comment on or make changes to this bug.