Bug 1028981 - "Add a Node to OpenShift Enterprise" option should be removed when using oo-install tools.
"Add a Node to OpenShift Enterprise" option should be removed when using oo-i...
Status: CLOSED NOTABUG
Product: OpenShift Container Platform
Classification: Red Hat
Component: Containers (Show other bugs)
2.0.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: N. Harrison Ripps
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-11 07:11 EST by Johnny Liu
Modified: 2017-03-08 12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-19 14:11:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Johnny Liu 2013-11-11 07:11:46 EST
Description of problem:
"./oo-install -a -e" will guide user to do selection:
<--snip-->
Select from the following installation scenarios.
You can also type '?' for Help or 'q' to Quit.":
1. Install OpenShift Enterprise
2. Add a Node to OpenShift Enterprise
Type a selection and press <return>: 
<--snip-->

Whatever user select #1 or #2, user always need follow the path to add a new node.
<--snip-->
Here are the details of your current deployment.
<--snip-->
Do you want to change the deployment info? (y/n/q/?) y

Choose from the following deployment configuration options:
1. Change the DNS configuration
2. Move an OpenShift role to a different host
3. Modify the information for an existing host
4. Add another Node host
5. Finish editing the deployment configuration
Type a selection and press <return>: 4
<--snip-->

So the step about select "Add a Node to OpenShift Enterprise" option is meanless, should be removed.


Version-Release number of selected component (if applicable):
Always

How reproducible:
Always

Steps to Reproduce:
1. Following https://access.redhat.com/site/articles/492873 to do the following operation.
$ curl http://oo-install.rhcloud.com/ose-2.0b/ -o oo-install
$ chmod +x ./oo-install
$ ./oo-install -e -a
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Luke Meyer 2013-11-19 09:10:15 EST
With the advent of statefulness of the deployment, adding a node could be performed by modifying the deployment to add a node host(s) and re-deploying, so I agree the "add a node" option is kind of superfluous; if it remains, it should probably drop directly into the "add a host" part of the dialog. I'm going to direct this to Harrison to discuss the best way to proceed. Whatever we do probably needs to work much the same for Origin.
Comment 3 N. Harrison Ripps 2013-11-19 13:04:05 EST
The confusion here is that:

"2. Add a Node to OpenShift Enterprise" refers to a workflow where we stand up a new node host and configure it to register itself with an existing Broker host. This workflow actually looks at the complete list of nodes in the config file and asks the user which one they want to deploy.

whereas

"4. Add another Node host" refers to the oo-install configuration file only, as in "add another node host to the overall configuration that you are describing, prior to any deployment activities"

However I agree that the distinction is moot if the workflow itself is stateful. We know the OSE workflow is stateful because Luke made it stateful. I think we can treat the Origin workflow as stateful because Puppet is inherently stateful in a similar way.

But, I should probably change:

"1. Install OpenShift Enterprise"

to

"1. Install or Expand an OpenShift Enterprise Deployment"

I can make these changes now.
Comment 4 N. Harrison Ripps 2013-11-19 14:11:13 EST
...but Mike Barrett convinced me otherwise. The up-front Node menu option is useful in some contexts. For instance, when you are running oo-install on a host that you intend to use as a new Node, where no oo-install-cfg.yml exists even though you will be plugging the Node into an existing OpenShift deployment.

Since there are cases where the up-front Add a Node option makes sense, and helps users, I am going to close this as NOTABUG for now.

Note You need to log in before you can comment on or make changes to this bug.