Bug 1029006 - Error in PREUN scriptlet in rpm package lightdm-1.4.0-2.fc18.armv6hl
Error in PREUN scriptlet in rpm package lightdm-1.4.0-2.fc18.armv6hl
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: lightdm (Show other bugs)
18
arm Linux
unspecified Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-11 08:18 EST by strsccgms
Modified: 2013-12-29 23:59 EST (History)
9 users (show)

See Also:
Fixed In Version: lightdm-1.4.5-3.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-29 23:59:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description strsccgms 2013-11-11 08:18:09 EST
Description of problem:After upgrade to Linux raspi 3.6.11 #1 PREEMPT Wed Oct 2 16:19:09 EDT 2013 armv6l armv6l armv6l GNU/Linux yum status shows

lightdm-1.4.0-2.fc18.armv6hl has missing requires of lightdm-gobject(armv6hl-32) = ('0', '1.4.0', '2.fc18')
lightdm-1.4.1-3.fc18.1307170533kf.armv6hl is a duplicate with lightdm-1.4.0-2.fc18.armv6hl
openssh-server-6.1p1-6.fc18.armv6hl has missing requires of openssh = ('0', '6.1p1', '6.fc18')
openssh-server-6.1p1-9.fc18.armv6hl is a duplicate with openssh-server-6.1p1-6.fc18.armv6hl
Error: check all

Attempting to remove the package via 
yum remove lightdm


Running Transaction
/var/tmp/rpm-tmp.Xihi2a: line 1: fg: no job control
error: %preun(lightdm-1.4.0-2.fc18.armv6hl) scriptlet failed, exit status 1
Error in PREUN scriptlet in rpm package lightdm-1.4.0-2.fc18.armv6hl
  Verifying  : lightdm-1.4.0-2.fc18.armv6hl                                                                                                        1/1 

Failed:
  lightdm.armv6hl 0:1.4.0-2.fc18 


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. yum remove lightdm


Actual results:


Running Transaction
/var/tmp/rpm-tmp.Xihi2a: line 1: fg: no job control
error: %preun(lightdm-1.4.0-2.fc18.armv6hl) scriptlet failed, exit status 1
Error in PREUN scriptlet in rpm package lightdm-1.4.0-2.fc18.armv6hl
  Verifying  : lightdm-1.4.0-2.fc18.armv6hl                                                                                                        1/1 

Failed:
  lightdm.armv6hl 0:1.4.0-2.fc18


Expected results:

remove lightdm successful


Additional info:
Comment 1 Zdeněk Pavlas 2013-11-11 08:24:33 EST
This is an error in package scriptlet.. Yum is dtrt when refusing to uninstall the package.
Comment 2 Fedora End Of Life 2013-12-21 09:44:45 EST
This message is a reminder that Fedora 18 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 18. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '18'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 18's end of life.

Thank you for reporting this issue and we are sorry that we may not be 
able to fix it before Fedora 18 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior to Fedora 18's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 3 Fedora Update System 2013-12-21 09:48:45 EST
lightdm-1.4.5-3.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/lightdm-1.4.5-3.fc18
Comment 4 Fedora Update System 2013-12-22 00:43:29 EST
Package lightdm-1.4.5-3.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing lightdm-1.4.5-3.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-23816/lightdm-1.4.5-3.fc18
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-12-29 23:59:07 EST
lightdm-1.4.5-3.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.