Bug 1029031 - Broken dependency on arm architecture: requires python-pexpect
Broken dependency on arm architecture: requires python-pexpect
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: yumex (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-11 09:14 EST by Patrick Monnerat
Modified: 2013-11-12 02:59 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-12 02:59:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrick Monnerat 2013-11-11 09:14:10 EST
Description of problem:
Cannot install yumex on arm architecture, because it depends on package python-pexpect that has arm in ExcludeArch

Version-Release number of selected component (if applicable):
3.0.13-1

How reproducible:
Always

Steps to Reproduce:
1. On an arm system, yum install yumex

Actual results:
Error: Package: yumex-3.0.13-1.fc21.noarch (build)
Requires: python-pexpect
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

Expected results:
Install success

Additional info:
This blocked my koji build of mate-applet-softupd, that BuildRequire yumex.
http://koji.fedoraproject.org/koji/taskinfo?taskID=6164766
Comment 1 Tim Lauridsen 2013-11-12 02:59:20 EST
There is not much is can do about it, if python-pexpect not is on arm, then yumex won't work.

Note You need to log in before you can comment on or make changes to this bug.