Bug 1029078 - gdm service fails to start (impossible to access the system)
gdm service fails to start (impossible to access the system)
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
20
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-11 10:49 EST by Pablo Rodríguez
Modified: 2014-08-30 17:02 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-30 17:02:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log from today (39.08 KB, text/x-log)
2013-11-14 12:34 EST, Pablo Rodríguez
no flags Details
last 200 lines from "journalctl -a" (21.28 KB, text/plain)
2013-11-14 12:36 EST, Pablo Rodríguez
no flags Details

  None (edit)
Description Pablo Rodríguez 2013-11-11 10:49:07 EST
Description of problem:

when loading  Fedora 19 (with updates from @updates-testing) system cannot be started.

I get a message like:

   Failed to start GNOME Display Manager
   See 'systemctl status gdm.service' for details.

Well, if the system doesn't start, I don't know how to check this details.

Also the Sendmail Mail Transport Agent and Client seem to fail to start properly, altought I don't get a failed message (only start and stop messages(.

Version-Release number of selected component (if applicable):

Well, I cannot check this (I'm writing from a live version of Crunchbang).

The version must be the latest one for Fedora 19 as released yesterday.

How reproducible:

Start Fedora.

Steps to Reproduce:
1. Simply wait.
2. GDM won't load.
3. System isn't loaded, so there is nothing to do with the computer

Actual results:

See above.

Expected results:

I need to use the computer.

Additional info:

How could I at least check the command 'systemctl status gdm.service'?

I login to a classic session. I don't know whether this may be relevant.
Comment 1 GeH 2013-11-12 13:03:16 EST
I have the same problem since yesterday.

systemctl status gdm.service :

nov. 11 05:39:30 gedoc04 systemd[1]: Unit gdm.service entered failed state.
nov. 11 05:39:30 gedoc04 systemd[1]: gdm.service holdoff time over, scheduling restart.
nov. 11 05:39:30 gedoc04 systemd[1]: Stopping GNOME Display Manager...
nov. 11 05:39:30 gedoc04 systemd[1]: Starting GNOME Display Manager...
nov. 11 05:41:00 gedoc04 systemd[1]: gdm.service operation timed out. Terminating.
nov. 11 05:41:00 gedoc04 systemd[1]: Failed to start GNOME Display Manager.
nov. 11 05:41:00 gedoc04 systemd[1]: Unit gdm.service entered failed state.
nov. 11 05:41:00 gedoc04 systemd[1]: gdm.service holdoff time over, scheduling restart.
nov. 11 05:41:00 gedoc04 systemd[1]: Stopping GNOME Display Manager...
nov. 11 05:41:00 gedoc04 systemd[1]: Starting GNOME Display Manager...


The boot process seems to loop at this stage, trying to launch gdm again and again.

I can boot into runlevel 3, then startx to get a usable desktop.
Comment 2 Pablo Rodríguez 2013-11-14 11:36:49 EST
Thanks for your reply, GeH.

I was able to boot in runlevel 3, but startx gives the following error:

Oh no! Something has gone wrong.
A problem has ocurred and the system can[t recover. Please log out and try again.

Now I have to find out what causes the error.
Comment 3 Pablo Rodríguez 2013-11-14 12:34:09 EST
Created attachment 824075 [details]
Xorg.0.log from today
Comment 4 Pablo Rodríguez 2013-11-14 12:36:00 EST
Created attachment 824078 [details]
last 200 lines from "journalctl -a"

Just in case it might help to solve the bug, I attach a copy Xorg.O.log, the last 200 lines from "journalctl -a". A log from GDM is not available from today.
Comment 5 GeH 2013-11-16 06:24:24 EST
No more problem today, after last update.

Maybe solved by last selinux-policy update : selinux-policy-3.12.1-74.13
Comment 6 Pablo Rodríguez 2013-11-16 13:19:33 EST
After being able to update the packages, everything works fine now.

Closing the bug myself as errata.
Comment 7 Pablo Rodríguez 2013-12-27 15:04:46 EST
Well, it seems that it is broken again in Fedora 20.

I'm experiencing another issue. When I run "startx", it starts a GNOME 3.10 session, which doesn't work for me.

Is there a way to invoke startx so it starts a classic session?

Many thanks for your help.
Comment 8 Pablo Rodríguez 2014-08-30 17:02:00 EDT
Well, closing the report myself, since nobody replied to my question.

Note You need to log in before you can comment on or make changes to this bug.