Bug 1029107 - adding localstorage Data Centers does not work
adding localstorage Data Centers does not work
Status: CLOSED DUPLICATE of bug 1023739
Product: oVirt
Classification: Community
Component: ovirt-engine-core (Show other bugs)
3.3
x86_64 Linux
unspecified Severity unspecified
: ---
: 3.3.4
Assigned To: Nobody's working on this, feel free to take it
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-11 11:51 EST by Sven Kieske
Modified: 2016-02-10 13:36 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-12 06:43:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sven Kieske 2013-11-11 11:51:27 EST
Description of problem:


Version-Release number of selected component (if applicable):
ovirt 3.3 engine

How reproducible:
setup 2 data centers with local storage, add data master storage
domains to these 2 data centers (this works)
add another data center with local storage, try to add another
master storage domain.
Steps to Reproduce:
1.setup 2 data centers with local storage, add data master storage
domains to these 2 data centers (this works)
2.add another data center with local storage, try to add another
master storage domain.
3.

Actual results:
ovirt management complains that the data domain
already exists, which is not true.


Expected results:
he data domain gets created just like the 2 before

Additional info:
This behaviour was introduced with version 3.3, we didn't see this
in version 3.2

This is regardless of node versions.

When we delete one of the 2 functional data centers
and then try to add the local storage domain inside
the third data center, we succeed.

If we then try to add the deleted data center 2
again, now as the third data center, the addition
of the local storage domain for _this_ data center
fails.

I have no logs, but maybe someone can try to reproduce this, all you need is 4
small hosts and about 30 minutes of time for the setup.
Comment 1 Sven Kieske 2013-11-12 06:43:57 EST
Hi,

we tested this again with 3.3.1 from beta repo from ovirt.org
and it seems gone, at least if you don't choose the same local storage path
for different compute nodes.

So this might be a duplicate of bug: https://bugzilla.redhat.com/show_bug.cgi?id=1023739

*** This bug has been marked as a duplicate of bug 1023739 ***

Note You need to log in before you can comment on or make changes to this bug.