Bug 1029121 - Unable to delete bundleGroup when assigned to role
Unable to delete bundleGroup when assigned to role
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Provisioning (Show other bugs)
JON 3.2
Unspecified Unspecified
urgent Severity urgent
: DR01
: JON 3.2.1
Assigned To: Libor Zoubek
Mike Foley
:
Depends On:
Blocks: jon321-blockers
  Show dependency treegraph
 
Reported: 2013-11-11 12:18 EST by Libor Zoubek
Modified: 2015-11-01 19:43 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-08 13:43:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Libor Zoubek 2013-11-11 12:18:32 EST
Version-Release number of selected component (if applicable):
JON 3.2.ER5

How reproducible: always


Steps to Reproduce:
1. create bundleGroup
2. assign it to any role
3. delete budnleGroup

Actual results: it fails, ConstraintViolationException


Expected results: Bundle group should be deleted. Same scenario works for resource groups.


Additional info:
Comment 1 Libor Zoubek 2014-02-07 12:13:25 EST
It's even worse. Checked on 3.2.0.GA deleting a bundleGroup does fail on ConstraintViolationException only if assigned role is assigned by some user. When this role has no users assigned it actually deletes the role as well.
Comment 2 Jay Shaughnessy 2014-02-10 10:24:53 EST
I discussed this with Libor and I think he has found the root cause.  He will be fixing and adding the necessary regression unit test.
Comment 3 Libor Zoubek 2014-02-10 11:24:27 EST
in master

commit a85776d3191076f851cbbcd45f2b6b01fc58d75d
Author: Libor Zoubek <lzoubek@redhat.com>
Date:   Mon Feb 10 17:08:11 2014 +0100
Comment 4 Jay Shaughnessy 2014-02-10 14:26:10 EST
release/jon3.2.x commit 90e0068993c5e0ce667f127f8f0c11e2d8bba7d4

    Cherry-Pick master a85776d3191076f851cbbcd45f2b6b01fc58d75d
    Signed-off-by: Jay Shaughnessy <jshaughn@redhat.com>
Comment 5 Simeon Pinder 2014-02-18 10:08:26 EST
Moving to ON_QA as available for testing in the following brew build:
https://brewweb.devel.redhat.com//buildinfo?buildID=336752

Note: the installed version is still JON 3.2.0.GA by design and this represents part of the payload for JON 3.2.1 also known as cumulative patch 1 for 3.2.0.GA.  How this will be delivered to customers is still being discussed.
Comment 6 Armine Hovsepyan 2014-02-19 06:48:22 EST
verified
bundle group is removed (from role as well), role without assigned user and with assigned is not removed during the bundle group remove.
Comment 7 Armine Hovsepyan 2014-03-19 16:20:54 EDT
re-verified in jon 3.2 + Cp1
Comment 9 Mike Foley 2014-05-08 13:43:55 EDT
JON 3.2.1 released week of 5/5/2014

Note You need to log in before you can comment on or make changes to this bug.