Bug 1029126 - Handle failure to decrypt LocalAdminPassword
Handle failure to decrypt LocalAdminPassword
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity low
: ---
: 3.6.0
Assigned To: Frantisek Kobzik
virt
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-11 12:43 EST by David Jaša
Modified: 2014-08-27 03:03 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-27 03:03:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 31387 master ABANDONED core: Detect inability to decrypt sysprep passwords Never

  None (edit)
Description David Jaša 2013-11-11 12:43:00 EST
Description of problem:
Currently, when RHEV-M fails to decrypt LocalAdminPassword, it passes the plaintext value to the sysprep file. The plaintext value can however contain forbidden characters for Windows that effectively break Windows sysprep mechanism. Based on above, the condition of non-decryptable LocalAdminPassword should be handled somehow:
  * don't run VM at all, issue Error in Events
  * don't set Admin Password at all in sysprep, issue Warning in Events, run VM

Version-Release number of selected component (if applicable):
is21 / rhevm-backend-3.3.0-0.31.beta1.el6ev.noarch

How reproducible:
always

Steps to Reproduce:
1. replace keys used to encrypt LocalAdminPassword in /etc/pki/ovirt-engine
2. run sealed Windows 7 VM with sysprep floppy attached
3.

Actual results:
Windows is likely to fail sysprep because the password may contain illegal characters

Expected results:
failure to decrypt password is detected and handled somehow

Additional info:
it takes going through some hoops to run into this bug so I think that it can have low priority.
Comment 1 Michal Skrivanek 2013-11-13 06:21:10 EST
makes sense to fail, not urgent though
Comment 2 Frantisek Kobzik 2014-08-27 03:03:38 EDT
Closing this since the problem reproduces only when the system is in illegal state (db values aren't encrypted by currently used keys).

This state is reported by engine in the logs (ERROR [...] Failed to decrypt value for property XYZ). As a consequence, plaintext value is used. It is up to administrator not to ignore this log line and ensure that password values are encrypted/decryptable correctly, or use plaintext at their own risk.

Note You need to log in before you can comment on or make changes to this bug.