Bug 1029173 - Deleting Jenkins Builder causes build failures.
Deleting Jenkins Builder causes build failures.
Status: CLOSED DEFERRED
Product: OpenShift Container Platform
Classification: Red Hat
Component: Image (Show other bugs)
1.2.1
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Timothy Williams
libra bugs
:
Depends On:
Blocks: 1040126
  Show dependency treegraph
 
Reported: 2013-11-11 15:33 EST by Eric Rich
Modified: 2016-04-15 15:48 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1040126 (view as bug list)
Environment:
Last Closed: 2016-04-15 15:48:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Rich 2013-11-11 15:33:55 EST
Description of problem:

If you delete the jenkins builder gear (from JBoss Developer Studio) and try to rebuild your application the build fails because the build can not be found. 

How reproducible:

Build an application;
Delete the builder gear;
Build the application again;

Additional info:

This seems to be caused because jenkins keeps a list of builders, and upon builder deletion (using REST calls) Jenkins does not get cleaned up.

Note You need to log in before you can comment on or make changes to this bug.