Bug 1029179 - [abrt] WARNING: CPU: 4 PID: 930 at drivers/gpu/drm/drm_crtc.c:1992 drm_mode_set_config_internal+0xd6/0xe0 [drm]()
[abrt] WARNING: CPU: 4 PID: 930 at drivers/gpu/drm/drm_crtc.c:1992 drm_mode_s...
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2013-11-11 15:52 EST by Corey Ashford
Modified: 2015-02-17 14:11 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2015-02-17 14:11:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
File: dmesg (105.58 KB, text/plain)
2013-11-11 15:52 EST, Corey Ashford
no flags Details

  None (edit)
Description Corey Ashford 2013-11-11 15:52:42 EST
Description of problem:
The only thing I was doing at the time, that I recall, was using Firefox to look at several web pages in several tabs, and also playing an MP3 file.

Then it seemed that Gnome or the video driver locked up and my screen froze.  I tried switching to an alternate console to attempt a reboot.

After many seconds, I did get another console.  Thinking that the system may have recovered, I tried switching 
back to console 1  (ctrl-alt 1), and I think that's when the kernel crash occurred.

So this kernel error seems to have occurred after a problem with the video driver or a gnome freeze of some sort.

Additional info:
reporter:       libreport-2.1.9
WARNING: CPU: 4 PID: 930 at drivers/gpu/drm/drm_crtc.c:1992 drm_mode_set_config_internal+0xd6/0xe0 [drm]()
Modules linked in: tcp_lp xt_CHECKSUM fuse nf_conntrack_ftp nf_conntrack_netbios_ns nf_conntrack_broadcast ipt_MASQUERADE ip6t_REJECT xt_conntrack rfcomm bnep ebtable_nat ebtable_broute bridge stp llc ebtable_filter ebtables ip6table_nat nf_conntrack_ipv6 nf_defrag_ipv6 nf_nat_ipv6 ip6table_mangle ip6table_security ip6table_raw ip6table_filter ip6_tables iptable_nat nf_conntrack_ipv4 nf_defrag_ipv4 nf_nat_ipv4 nf_nat nf_conntrack iptable_mangle iptable_security iptable_raw tun uvcvideo videobuf2_vmalloc videobuf2_memops videobuf2_core videodev media arc4 iwldvm mac80211 snd_hda_codec_hdmi coretemp kvm_intel kvm btusb bluetooth snd_hda_codec_conexant iTCO_wdt iTCO_vendor_support sdhci_pci sdhci mmc_core microcode snd_hda_intel snd_hda_codec joydev serio_raw snd_hwdep iwlwifi snd_seq i7core_edac snd_seq_device edac_core cfg80211 e1000e snd_pcm ptp pps_core lpc_ich mfd_core snd_page_alloc i2c_i801 snd_timer thinkpad_acpi mei_me mei snd tpm_tis soundcore tpm rfkill tpm_bios shpchp acpi_cpufreq mperf binfmt_misc uinput dm_crypt nouveau i2c_algo_bit drm_kms_helper ttm crc32c_intel firewire_ohci drm firewire_core crc_itu_t i2c_core mxm_wmi video wmi [last unloaded: nf_conntrack_ftp]
CPU: 4 PID: 930 Comm: Xorg Not tainted 3.11.6-201.fc19.x86_64 #1
Hardware name: LENOVO 4389AN7/4389AN7, BIOS 6NET84WW (1.45 ) 10/03/2012
 0000000000000009 ffff8802a3563ab8 ffffffff8164770b 0000000000000000
 ffff8802a3563af0 ffffffff8106715d ffff8802ad3b56a0 0000000000000000
 ffff8802b0e5a000 ffff8802ad3bb860 0000000000000080 ffff8802a3563b00
Call Trace:
 [<ffffffff8164770b>] dump_stack+0x45/0x56
 [<ffffffff8106715d>] warn_slowpath_common+0x7d/0xa0
 [<ffffffff8106723a>] warn_slowpath_null+0x1a/0x20
 [<ffffffffa004dae6>] drm_mode_set_config_internal+0xd6/0xe0 [drm]
 [<ffffffffa0085641>] drm_fb_helper_set_par+0x71/0xf0 [drm_kms_helper]
 [<ffffffff81345561>] fb_set_var+0x191/0x430
 [<ffffffff8109ea70>] ? update_curr+0x70/0x160
 [<ffffffff81350d21>] fbcon_blank+0x1d1/0x2d0
 [<ffffffff813c6654>] do_unblank_screen+0xb4/0x1e0
 [<ffffffff813bc57a>] complete_change_console+0x5a/0xe0
 [<ffffffff813bd59e>] vt_ioctl+0xf9e/0x1150
 [<ffffffff81646de7>] ? avc_compute_av+0x1a3/0x1b5
 [<ffffffff813b13e5>] tty_ioctl+0x275/0xb70
 [<ffffffff8129a1e9>] ? avc_has_perm_flags+0xc9/0x180
 [<ffffffff811b9e3d>] do_vfs_ioctl+0x2dd/0x4b0
 [<ffffffff811ba091>] SyS_ioctl+0x81/0xa0
 [<ffffffff816521de>] ? do_page_fault+0xe/0x10
 [<ffffffff81656919>] system_call_fastpath+0x16/0x1b
Comment 1 Corey Ashford 2013-11-11 15:52:52 EST
Created attachment 822626 [details]
File: dmesg
Comment 2 Corey Ashford 2013-11-11 15:55:27 EST
The hardware in question is an Lenova W510 Thinkpad
Comment 3 Fedora End Of Life 2015-01-09 15:33:33 EST
This message is a notice that Fedora 19 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 19. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained. Approximately 4 (four) weeks from now this bug will
be closed as EOL if it remains open with a Fedora 'version' of '19'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 19 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 4 Fedora End Of Life 2015-02-17 14:11:37 EST
Fedora 19 changed to end-of-life (EOL) status on 2015-01-06. Fedora 19 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.