Bug 1029184 - Integrity of the app-deployments directory must ensured during git-push
Integrity of the app-deployments directory must ensured during git-push
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Image (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Paul Morie
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-11 16:04 EST by Paul Morie
Modified: 2015-05-14 20:34 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-29 19:50:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
upgrade error log (150.85 KB, text/plain)
2013-11-12 02:18 EST, Jianwei Hou
no flags Details

  None (edit)
Description Paul Morie 2013-11-11 16:04:59 EST
The app-deployments directory is user-owned, making it possible for this directory to be corrupted by user actions.  The expected behavior is that this directory should be analyzed for corruption on each git push to ensure that the push works correctly even when app-deployments has been corrupted.  Each problem found with this directory should be fixed.
Comment 2 Jianwei Hou 2013-11-12 02:18:09 EST
Created attachment 822773 [details]
upgrade error log

Tested on devenv-stage_566 with rhc-node-1.16.11-1.el6oso.x86_64
This is making the oo-admin-ugrade fail, found all of the apps failed due to a same error 'undefined method `check_deployments_integrity'. Didn't find the definition of 'check_deployments_integrity' from both our repos.
Comment 3 Jianwei Hou 2013-11-12 02:54:47 EST
Sorry, https://github.com/openshift/origin-server/pull/4162 is not merged in my test environment yet, will retest this.
Comment 4 Jianwei Hou 2013-11-12 03:30:11 EST
Verified with rubygem-openshift-origin-node-1.16.14-1 and rhc-node-1.16.11-1

The migration was successful, and user can push and deploy their apps after migration.
Comment 5 openshift-github-bot 2013-11-12 14:57:03 EST
Commit pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/a71efea6dd7aa61089834a25f91b512b00c51c34
Fix bug 1029184: deployments integrity check

Note You need to log in before you can comment on or make changes to this bug.