Bug 1029207 - [abrt] python-setuptools-0.6.36-1.fc19: setup.py:100:check_requirements:ImportError: You need `Cython` version 0.17 or later.
[abrt] python-setuptools-0.6.36-1.fc19: setup.py:100:check_requirements:Impor...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: python-setuptools (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Toshio Ernie Kuratomi
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:4220a03ad1f344b651d52882a38...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-11 16:52 EST by Tobias Schöls
Modified: 2013-11-13 17:48 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-13 17:48:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (2.40 KB, text/plain)
2013-11-11 16:52 EST, Tobias Schöls
no flags Details
File: environ (2.72 KB, text/plain)
2013-11-11 16:52 EST, Tobias Schöls
no flags Details

  None (edit)
Description Tobias Schöls 2013-11-11 16:52:27 EST
Version-Release number of selected component:
python-setuptools-0.6.36-1.fc19

Additional info:
reporter:       libreport-2.1.9
cmdline:        /usr/bin/python /usr/bin/easy_install --install-dir=/home/tobi/workspace/scikit-image --user scikit-image
dso_list:       python-libs-2.7.5-8.fc19.x86_64
executable:     /usr/bin/easy_install
kernel:         3.11.6-200.fc19.x86_64
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
setup.py:100:check_requirements:ImportError: You need `Cython` version 0.17 or later.

Traceback (most recent call last):
  File "/usr/bin/easy_install", line 9, in <module>
    load_entry_point('distribute==0.6.36', 'console_scripts', 'easy_install')()
  File "/usr/lib/python2.7/site-packages/setuptools/command/easy_install.py", line 1941, in main
    with_ei_usage(lambda:
  File "/usr/lib/python2.7/site-packages/setuptools/command/easy_install.py", line 1922, in with_ei_usage
    return f()
  File "/usr/lib/python2.7/site-packages/setuptools/command/easy_install.py", line 1945, in <lambda>
    distclass=DistributionWithoutHelpCommands, **kw
  File "/usr/lib64/python2.7/distutils/core.py", line 152, in setup
    dist.run_commands()
  File "/usr/lib64/python2.7/distutils/dist.py", line 953, in run_commands
    self.run_command(cmd)
  File "/usr/lib64/python2.7/distutils/dist.py", line 972, in run_command
    cmd_obj.run()
  File "/usr/lib/python2.7/site-packages/setuptools/command/easy_install.py", line 358, in run
    self.easy_install(spec, not self.no_deps)
  File "/usr/lib/python2.7/site-packages/setuptools/command/easy_install.py", line 602, in easy_install
    return self.install_item(spec, dist.location, tmpdir, deps)
  File "/usr/lib/python2.7/site-packages/setuptools/command/easy_install.py", line 632, in install_item
    dists = self.install_eggs(spec, download, tmpdir)
  File "/usr/lib/python2.7/site-packages/setuptools/command/easy_install.py", line 827, in install_eggs
    return self.build_and_install(setup_script, setup_base)
  File "/usr/lib/python2.7/site-packages/setuptools/command/easy_install.py", line 1107, in build_and_install
    self.run_setup(setup_script, setup_base, args)
  File "/usr/lib/python2.7/site-packages/setuptools/command/easy_install.py", line 1093, in run_setup
    run_setup(setup_script, args)
  File "/usr/lib/python2.7/site-packages/setuptools/sandbox.py", line 33, in run_setup
    lambda: execfile(
  File "/usr/lib/python2.7/site-packages/setuptools/sandbox.py", line 81, in run
    return func()
  File "/usr/lib/python2.7/site-packages/setuptools/sandbox.py", line 35, in <lambda>
    {'__file__':setup_script, '__name__':'__main__'}
  File "setup.py", line 105, in <module>
  File "setup.py", line 100, in check_requirements
ImportError: You need `Cython` version 0.17 or later.

Local variables in innermost frame:
min_version: (0, 17)
dep_error: True
package_name: 'Cython'
Comment 1 Tobias Schöls 2013-11-11 16:52:35 EST
Created attachment 822634 [details]
File: backtrace
Comment 2 Tobias Schöls 2013-11-11 16:52:38 EST
Created attachment 822635 [details]
File: environ
Comment 3 Toshio Ernie Kuratomi 2013-11-11 17:18:02 EST
This looks like you don't have the Cython package installed.

yum install Cython

Then run your easy_install command.

Note You need to log in before you can comment on or make changes to this bug.