Bug 1029225 - Can't install lxc-templates due to conflict between dpkg and man-pages-it
Can't install lxc-templates due to conflict between dpkg and man-pages-it
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: man-pages-it (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mike FABIAN
Fedora Extras Quality Assurance
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-11 17:33 EST by Greg Ward
Modified: 2013-11-26 23:36 EST (History)
7 users (show)

See Also:
Fixed In Version: man-pages-it-3.15-2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-26 00:12:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Greg Ward 2013-11-11 17:33:29 EST
Description of problem:
Installing lxc-templates fails with the following output:

"""
$ sudo yum install -y lxc-templates
Failed to set locale, defaulting to C
Loaded plugins: etckeeper, langpacks, refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package lxc-templates.x86_64 0:0.9.0-2.fc20 will be installed
--> Processing Dependency: dpkg for package: lxc-templates-0.9.0-2.fc20.x86_64
--> Processing Dependency: debootstrap for package: lxc-templates-0.9.0-2.fc20.x86_64
--> Processing Dependency: busybox for package: lxc-templates-0.9.0-2.fc20.x86_64
--> Running transaction check
---> Package busybox.x86_64 1:1.19.4-11.fc20 will be installed
---> Package debootstrap.noarch 0:1.0.53-1.fc20 will be installed
---> Package dpkg.x86_64 0:1.16.12-1.fc20 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

==========================================================================================================================================================
 Package                              Arch                          Version                                  Repository                              Size
==========================================================================================================================================================
Installing:
 lxc-templates                        x86_64                        0.9.0-2.fc20                             updates-testing                         29 k
Installing for dependencies:
 busybox                              x86_64                        1:1.19.4-11.fc20                         fedora                                 691 k
 debootstrap                          noarch                        1.0.53-1.fc20                            fedora                                  68 k
 dpkg                                 x86_64                        1.16.12-1.fc20                           fedora                                 1.2 M

Transaction Summary
==========================================================================================================================================================
Install  1 Package (+3 Dependent packages)

Total size: 2.0 M
Installed size: 7.2 M
Downloading packages:
Running transaction check
Running transaction test


Transaction check error:
  file /usr/share/man/it/man5/dpkg.cfg.5.gz from install of dpkg-1.16.12-1.fc20.x86_64 conflicts with file from package man-pages-it-3.15-2.fc20.noarch

Error Summary
-------------
"""

Same thing if I just narrow the install down to 'dpkg'.

man-pages-it was already installed on my system automatically (this is a brand-new Fedora 20 installation), so I assume it's a default package. Thus, I'm blaming this one on dpkg.

Version-Release number of selected component (if applicable):
1.16.12-1.fc20

How reproducible:
100%

Steps to Reproduce:
1. ensure that man-pages-it is installed
2. try "sudo yum install dpkg"

Actual results:
- installation fails with conflict

Expected results:
- successful installation

Additional info:

Easy workaround: sudo yum remove man-pages-it. No harm there unless you need to read man pages in Italian!
Comment 1 Sergio Monteiro Basto 2013-11-12 10:00:18 EST
Hi, Thanks for your report , I will check that ASAP, which means this week ...
Comment 2 Sergio Monteiro Basto 2013-11-13 00:06:11 EST
Hi, 
new dpkg version (1.16.12) brings some man pages for locale it [1], 
man-pages-it also have dpkg man pages [2]
I think dpkg is the best man pages because is the source and seems more updated, by dates wrote on files . 
I check and man pages are not equal , but are similar ...
Could you remove the conflict files [2] for F19+ ?
Thanks,


[1] 
repoquery --enablerepo=updates-testing -l dpkg | grep /it
/usr/share/locale/it/LC_MESSAGES/dpkg.mo
/usr/share/man/it/man1/dpkg-deb.1.gz
/usr/share/man/it/man1/dpkg-query.1.gz
/usr/share/man/it/man1/dpkg-split.1.gz
/usr/share/man/it/man1/dpkg.1.gz
/usr/share/man/it/man5/dpkg.cfg.5.gz

[2]
rpm -ql man-pages-it | grep dpkg
/usr/share/man/it/man5/dpkg.cfg.5.gz
/usr/share/man/it/man8/dpkg.8.gz
Comment 3 Fedora Update System 2013-11-13 01:40:25 EST
man-pages-it-3.15-3.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/man-pages-it-3.15-3.fc20
Comment 4 Sergio Monteiro Basto 2013-11-13 02:09:27 EST
Hi, thanks, we also need this applied on F19 , 

repoquery --enablerepo=updates-testing dpkg
dpkg-0:1.16.12-1.fc19.x86_64

Best regards,
Comment 5 Mike FABIAN 2013-11-13 02:11:08 EST
Ah, OK, doing it for f19 as well ...
Comment 6 Fedora Update System 2013-11-13 02:24:24 EST
man-pages-it-3.15-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/man-pages-it-3.15-2.fc19
Comment 7 Fedora Update System 2013-11-13 22:32:54 EST
Package man-pages-it-3.15-3.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing man-pages-it-3.15-3.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-21259/man-pages-it-3.15-3.fc20
then log in and leave karma (feedback).
Comment 8 Greg Ward 2013-11-14 09:01:27 EST
Looks good! I removed lxc* and dpkg (had already removed man-pages-it as a workaround). Installed man-pages-it. Then installed lxc and lxc-templates, which dragged in dpkg as a dependency. It all worked perfectly.

Thanks!
Comment 9 Fedora Update System 2013-11-26 00:12:17 EST
man-pages-it-3.15-3.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2013-11-26 23:36:07 EST
man-pages-it-3.15-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.