Bug 1029300 - Red Hat Storage Server installation from RH Satellite Server fails, due to missing dependency packages, and package conflict issues
Red Hat Storage Server installation from RH Satellite Server fails, due to mi...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: redhat-storage-server (Show other bugs)
2.1
All Linux
urgent Severity urgent
: ---
: ---
Assigned To: Bala.FA
Rejy M Cyriac
: TestBlocker, ZStream
Depends On:
Blocks: 994889
  Show dependency treegraph
 
Reported: 2013-11-12 01:13 EST by Gowrishankar Rajaiyan
Modified: 2015-11-22 21:58 EST (History)
6 users (show)

See Also:
Fixed In Version: redhat-storage-server-2.1.1.0-5.el6rhs
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-27 10:47:25 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
yum_output_initial (66.85 KB, text/plain)
2013-11-12 11:20 EST, Rejy M Cyriac
no flags Details
yum_output_initial_after_channel_add (56.33 KB, text/plain)
2013-11-12 11:21 EST, Rejy M Cyriac
no flags Details
yum_output_initial_after_channel_add_and_exclusions (81.84 KB, text/plain)
2013-11-12 11:21 EST, Rejy M Cyriac
no flags Details
yum.debug.output (5.69 MB, text/plain)
2013-11-13 05:26 EST, Rejy M Cyriac
no flags Details

  None (edit)
Description Gowrishankar Rajaiyan 2013-11-12 01:13:05 EST
[root@server1 ~]# yum update --nogpgcheck
...
--> Finished Dependency Resolution
Error: Package: redhat-storage-server-2.1.1.0-2.el6rhs.noarch (rhel-x86_64-server-6-rhs-2.1)
           Requires: gpg-pubkey-fd431d51
Error: Package: redhat-storage-server-2.1.1.0-2.el6rhs.noarch (rhel-x86_64-server-6-rhs-2.1)
           Requires: gpg-pubkey
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
Comment 1 Bala.FA 2013-11-12 01:25:47 EST
What type of installation made to the system? ISO? Satellite?
Comment 2 Gowrishankar Rajaiyan 2013-11-12 01:36:39 EST
Satellite.
Comment 3 Bala.FA 2013-11-12 01:44:50 EST
Patch is at https://code.engineering.redhat.com/gerrit/#/c/15537/
Comment 4 Rejy M Cyriac 2013-11-12 11:20:37 EST
Created attachment 823041 [details]
yum_output_initial
Comment 5 Rejy M Cyriac 2013-11-12 11:21:03 EST
Created attachment 823042 [details]
yum_output_initial_after_channel_add
Comment 6 Rejy M Cyriac 2013-11-12 11:21:24 EST
Created attachment 823043 [details]
yum_output_initial_after_channel_add_and_exclusions
Comment 7 Rejy M Cyriac 2013-11-12 11:23:39 EST
On installing RHS system through RH Satellite server, redhat-storage-server-2.1.1.0-3.el6rhs still *fails to install* , due to missing dependency packages and package conflicts.

------------------------------------------------------------------
Error: Package: redhat-storage-server-2.1.1.0-3.el6rhs.noarch (rhel-x86_64-server-6-rhs-2.1)
           Requires: setools
Error: Package: redhat-storage-server-2.1.1.0-3.el6rhs.noarch (rhel-x86_64-server-6-rhs-2.1)
           Requires: yum-plugin-protectbase
Error: Package: redhat-storage-server-2.1.1.0-3.el6rhs.noarch (rhel-x86_64-server-6-rhs-2.1)
           Requires: yum-plugin-fastestmirror
Error: Package: redhat-storage-server-2.1.1.0-3.el6rhs.noarch (rhel-x86_64-server-6-rhs-2.1)
           Requires: yum-plugin-upgrade-helper
Error: samba4 conflicts with samba-3.6.9-160.7.el6rhs.x86_64
Error: Package: redhat-storage-server-2.1.1.0-3.el6rhs.noarch (rhel-x86_64-server-6-rhs-2.1)
           Requires: setools-libs-tcl
Error: Package: redhat-storage-server-2.1.1.0-3.el6rhs.noarch (rhel-x86_64-server-6-rhs-2.1)
           Requires: yum-plugin-merge-conf
Error: Package: redhat-storage-server-2.1.1.0-3.el6rhs.noarch (rhel-x86_64-server-6-rhs-2.1)
           Requires: setools-gui
Error: Package: redhat-storage-server-2.1.1.0-3.el6rhs.noarch (rhel-x86_64-server-6-rhs-2.1)
           Requires: yum-plugin-keys
Error: samba4-common conflicts with samba-common-3.6.9-160.7.el6rhs.x86_64
Error: Package: redhat-storage-server-2.1.1.0-3.el6rhs.noarch (rhel-x86_64-server-6-rhs-2.1)
           Requires: yum-plugin-priorities
Error: Package: redhat-storage-server-2.1.1.0-3.el6rhs.noarch (rhel-x86_64-server-6-rhs-2.1)
           Requires: yum-plugin-filter-data
Error: Package: redhat-storage-server-2.1.1.0-3.el6rhs.noarch (rhel-x86_64-server-6-rhs-2.1)
           Requires: bwidget
Error: Package: redhat-storage-server-2.1.1.0-3.el6rhs.noarch (rhel-x86_64-server-6-rhs-2.1)
           Requires: yum-plugin-list-data
Error: Package: redhat-storage-server-2.1.1.0-3.el6rhs.noarch (rhel-x86_64-server-6-rhs-2.1)
           Requires: yum-plugin-tsflags
------------------------------------------------------------------

Missing dependency packages
----------------------------

The packages reported to be missing are the following

setools
yum-plugin-protectbase
yum-plugin-fastestmirror
yum-plugin-upgrade-helper
setools-libs-tcl
yum-plugin-merge-conf
setools-gui
yum-plugin-keys
yum-plugin-priorities
yum-plugin-filter-data
bwidget
yum-plugin-list-data
yum-plugin-tsflags

These packages are *available* from the channel ' rhel-x86_64-server-optional-6.4.z ', which is currently *not* a prescribed channel for RHS. If the RHS system is subscribed to this channel, the missing dependency packages error does not occur.

Package Conflicts
-----------------

The package conflicts are related to the following samba4 related packages

samba4
samba4-common
samba4-client

It is not clear why these packages are being called, during the installation of redhat-storage-server package. RHS only requires samba4-libs package, as a dependency of sssd, and that package does not create any conflict.

---------

Attached to the BZ are the following outputs, from the yum commands also provided, on the RHS system which failed to have the redhat-storage-server package installed.

1) yum_output_initial - output from 'yum install redhat-storage-server' command run on the system initially, subscribed to only the RHS prescribed channels - 
rhel-x86_64-server-6.4.z
rhel-x86_64-server-6-rhs-2.1
rhel-x86_64-server-sfs-6.4.z

2) yum_output_initial_after_channel_add - output from 'yum install redhat-storage-server' command, after adding the rhel-x86_64-server-optional-6.4.z channel

3) yum_output_initial_after_channel_add_and_exclusions - output from running 'yum install redhat-storage-server -x samba4 -x samba4-common -x samba4-client' command, in addition to adding the rhel-x86_64-server-optional-6.4.z channel
Comment 8 Rejy M Cyriac 2013-11-12 22:58:40 EST
Setting TestBlocker since RHS Server installation through RH Satellite server is broken due to the reported issue.
Comment 9 Gowrishankar Rajaiyan 2013-11-13 00:47:29 EST
comment #7 explicitly specifies the issue with redhat-storage-server-2.1.1.0-3.el6rhs .. which is "Fixed in Version".

Can you please explain why this is ON_QA ?
Comment 10 Sudhir D 2013-11-13 02:58:05 EST
On the latest available build redhat-storage-server-2.1.1.0-3.el6rhs the issue still exist. Marking FailedQA.

Rejy also tested upgrade (2.1 GA to latest package of 2.1) from satellite and that fails too.
Comment 11 Rejy M Cyriac 2013-11-13 05:25:19 EST
Working along with Bala, on the issue of samba4* packages conflicting with the required samba*-3.* packages during the installation of redhat-storage-server package, it was observed from the debug outputs of yum, that the samba4 and samba4-client packages are also being considered along with the samba*-3.* packages while resolving 'what-provides' dependencies, and it appears that the samba4 and samba4-client packages emerge the winner in the comparison.

The output given below gives some clarity to this.

-----------------------------------------------

# yum whatprovides samba-client
Loaded plugins: product-id, rhnplugin, security, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
This system is receiving updates from RHN Classic or RHN Satellite.
samba4-client-4.0.0-55.el6.rc4.x86_64 : Samba client programs
Repo        : rhel-x86_64-server-6.4.z
Matched from:
Other       : samba-client



samba-client-3.5.4-68.el6_0.2.x86_64 : Samba client programs
Repo        : rhel-x86_64-server-6.4.z
Matched from:
.....

-----------------------------------------------

The conflicts do not happen when the samba4 and samba4-client packages are explicitly excluded from the yum transaction, as in

# yum  install redhat-storage-server -x samba4-client -x samba

The debug output from the failed yum transaction is attached as yum.debug.output
Comment 12 Rejy M Cyriac 2013-11-13 05:26:42 EST
Created attachment 823339 [details]
yum.debug.output
Comment 13 Bala.FA 2013-11-13 05:33:59 EST
(In reply to Rejy M Cyriac from comment #7)
> On installing RHS system through RH Satellite server,
> redhat-storage-server-2.1.1.0-3.el6rhs still *fails to install* , due to
> missing dependency packages and package conflicts.
> 
> ------------------------------------------------------------------
> Error: Package: redhat-storage-server-2.1.1.0-3.el6rhs.noarch
> (rhel-x86_64-server-6-rhs-2.1)
>            Requires: setools
> Error: Package: redhat-storage-server-2.1.1.0-3.el6rhs.noarch
> (rhel-x86_64-server-6-rhs-2.1)
>            Requires: yum-plugin-protectbase
> Error: Package: redhat-storage-server-2.1.1.0-3.el6rhs.noarch
> (rhel-x86_64-server-6-rhs-2.1)
>            Requires: yum-plugin-fastestmirror
> Error: Package: redhat-storage-server-2.1.1.0-3.el6rhs.noarch
> (rhel-x86_64-server-6-rhs-2.1)
>            Requires: yum-plugin-upgrade-helper
> Error: samba4 conflicts with samba-3.6.9-160.7.el6rhs.x86_64
> Error: Package: redhat-storage-server-2.1.1.0-3.el6rhs.noarch
> (rhel-x86_64-server-6-rhs-2.1)
>            Requires: setools-libs-tcl
> Error: Package: redhat-storage-server-2.1.1.0-3.el6rhs.noarch
> (rhel-x86_64-server-6-rhs-2.1)
>            Requires: yum-plugin-merge-conf
> Error: Package: redhat-storage-server-2.1.1.0-3.el6rhs.noarch
> (rhel-x86_64-server-6-rhs-2.1)
>            Requires: setools-gui
> Error: Package: redhat-storage-server-2.1.1.0-3.el6rhs.noarch
> (rhel-x86_64-server-6-rhs-2.1)
>            Requires: yum-plugin-keys
> Error: samba4-common conflicts with samba-common-3.6.9-160.7.el6rhs.x86_64
> Error: Package: redhat-storage-server-2.1.1.0-3.el6rhs.noarch
> (rhel-x86_64-server-6-rhs-2.1)
>            Requires: yum-plugin-priorities
> Error: Package: redhat-storage-server-2.1.1.0-3.el6rhs.noarch
> (rhel-x86_64-server-6-rhs-2.1)
>            Requires: yum-plugin-filter-data
> Error: Package: redhat-storage-server-2.1.1.0-3.el6rhs.noarch
> (rhel-x86_64-server-6-rhs-2.1)
>            Requires: bwidget
> Error: Package: redhat-storage-server-2.1.1.0-3.el6rhs.noarch
> (rhel-x86_64-server-6-rhs-2.1)
>            Requires: yum-plugin-list-data
> Error: Package: redhat-storage-server-2.1.1.0-3.el6rhs.noarch
> (rhel-x86_64-server-6-rhs-2.1)
>            Requires: yum-plugin-tsflags
> ------------------------------------------------------------------
> 
> Missing dependency packages
> ----------------------------
> 
> The packages reported to be missing are the following
> 
> setools
> yum-plugin-protectbase
> yum-plugin-fastestmirror
> yum-plugin-upgrade-helper
> setools-libs-tcl
> yum-plugin-merge-conf
> setools-gui
> yum-plugin-keys
> yum-plugin-priorities
> yum-plugin-filter-data
> bwidget
> yum-plugin-list-data
> yum-plugin-tsflags
> 

These packages are removed from dependency list now (and they are available in optional channel which is not recommended to add it by default).  However these packages are installed by ISO and not by Satellite.  This difference will be exist.


> These packages are *available* from the channel '
> rhel-x86_64-server-optional-6.4.z ', which is currently *not* a prescribed
> channel for RHS. If the RHS system is subscribed to this channel, the
> missing dependency packages error does not occur.
> 
> Package Conflicts
> -----------------
> 
> The package conflicts are related to the following samba4 related packages
> 
> samba4
> samba4-common
> samba4-client
> 

As per discussion with Rejy, yum pulls package for samba-client where samba4-client wins over samba-client-3.  Currently the fix sets samba-client < 4.  For more detail, refer comment #11 and comment #12.

However when doing 'yum localinstall redhat-storage-server-2.1.1.0-3.noarch.rpm' gets version 3 of samba-client.



> It is not clear why these packages are being called, during the installation
> of redhat-storage-server package. RHS only requires samba4-libs package, as
> a dependency of sssd, and that package does not create any conflict.
> 
> ---------
> 
> Attached to the BZ are the following outputs, from the yum commands also
> provided, on the RHS system which failed to have the redhat-storage-server
> package installed.
> 
> 1) yum_output_initial - output from 'yum install redhat-storage-server'
> command run on the system initially, subscribed to only the RHS prescribed
> channels - 
> rhel-x86_64-server-6.4.z
> rhel-x86_64-server-6-rhs-2.1
> rhel-x86_64-server-sfs-6.4.z
> 
> 2) yum_output_initial_after_channel_add - output from 'yum install
> redhat-storage-server' command, after adding the
> rhel-x86_64-server-optional-6.4.z channel
> 
> 3) yum_output_initial_after_channel_add_and_exclusions - output from running
> 'yum install redhat-storage-server -x samba4 -x samba4-common -x
> samba4-client' command, in addition to adding the
> rhel-x86_64-server-optional-6.4.z channel
Comment 14 Bala.FA 2013-11-13 05:34:33 EST
Patch is under review at https://code.engineering.redhat.com/gerrit/15627
Comment 15 Rejy M Cyriac 2013-11-14 03:00:53 EST
Glad to report that the 'Missing dependency packages' issue has been resolved with the removal of the associated packages from the dependency list.

---------

However, I am sorry to report that the 'Package Conflicts' issue remains, This is probably because the fix involved only samba-client, and missed samba, which is also part of the 'requires' set for redhat-storage-server package.

-----------------------------------------------------
Error: samba4-common conflicts with samba-common-3.6.9-160.7.el6rhs.x86_64
Error: samba4 conflicts with samba-3.6.9-160.7.el6rhs.x86_64
-----------------------------------------------------

The samba4-common is being pulled in as a dependency to samba4, which emerged the winner in the 'compare_providers()' run for samba.

This is further confirmed by the successful run of the yum install command with only samba4 explicitly excluded.

# yum install redhat-storage-server -x samba4

The relevant snippets from the output of the failed 'yum install redhat-storage-server' command is given below. It can be seen that samba4-client is ignored as expected, but samba4 comes into the run for samba candidates, and it is all downhill from there. :-/

-----------------------------------------------------
redhat-storage-server-2.1.1.0-4.el6rhs.noarch requires: samba-client < 4
--> Processing Dependency: samba-client < 4 for package: redhat-storage-server-2.1.1.0-4.el6rhs.noarch
....
Running compare_providers() for [<YumAvailablePackageSqlite : samba-client-3.5.4-68.el6.x86_64 (0x1aa97d0)>, <YumAvailablePackageSqlite : samba-client-3.5.4-68.el6_0.1.x86_64 (0x1aa9d10)>, <YumAvailablePackageSqlite : samba-client-3.5.4-68.el6_0.2.x86_64 (0x1aa9f10)>, <YumAvailablePackageSqlite : samba-client-3.5.6-86.el6.x86_64 (0x1aa9e10)>, <YumAvailablePackageSqlite : samba-client-3.5.6-86.el6_1.4.x86_64 (0x1aa9dd0)>, <YumAvailablePackageSqlite : samba-client-3.5.10-114.el6.x86_64 (0x1aa9fd0)>, <YumAvailablePackageSqlite : samba-client-3.5.10-115.el6_2.x86_64 (0x1aa9cd0)>, <YumAvailablePackageSqlite : samba-client-3.5.10-116.el6_2.x86_64 (0x1aa9ed0)>, <YumAvailablePackageSqlite : samba-client-3.5.10-125.el6.x86_64 (0x1aa9e50)>, <YumAvailablePackageSqlite : samba-client-3.6.9-151.el6.x86_64 (0x1aa9d50)>, <YumAvailablePackageSqlite : samba-client-3.6.9-151.el6_4.1.x86_64 (0x1aa9c90)>, <YumAvailablePackageSqlite : samba-client-3.6.9-160.3.el6rhs.x86_64 (0x1aa9850)>, <YumAvailablePackageSqlite : samba-client-3.6.9-160.5.el6rhs.x86_64 (0x1aa9810)>, <YumAvailablePackageSqlite : samba-client-3.6.9-160.6.el6rhs.x86_64 (0x1aa98d0)>, <YumAvailablePackageSqlite : samba-client-3.6.9-160.7.el6rhs.x86_64 (0x1aa9890)>]
....
Best Order: [(<YumAvailablePackageSqlite : samba-client-3.6.9-160.7.el6rhs.x86_64 (0x1aa9890)>, 988), (<YumAvailablePackageSqlite : samba-client-3.6.9-160.6.el6rhs.x86_64 (0x1aa98d0)>, -14336), (<YumAvailablePackageSqlite : samba-client-3.6.9-160.5.el6rhs.x86_64 (0x1aa9810)>, -14336), (<YumAvailablePackageSqlite : samba-client-3.6.9-160.3.el6rhs.x86_64 (0x1aa9850)>, -14336), (<YumAvailablePackageSqlite : samba-client-3.6.9-151.el6_4.1.x86_64 (0x1aa9c90)>, -14336), (<YumAvailablePackageSqlite : samba-client-3.6.9-151.el6.x86_64 (0x1aa9d50)>, -14336), (<YumAvailablePackageSqlite : samba-client-3.5.10-125.el6.x86_64 (0x1aa9e50)>, -14336), (<YumAvailablePackageSqlite : samba-client-3.5.10-116.el6_2.x86_64 (0x1aa9ed0)>, -14336), (<YumAvailablePackageSqlite : samba-client-3.5.10-115.el6_2.x86_64 (0x1aa9cd0)>, -14336), (<YumAvailablePackageSqlite : samba-client-3.5.10-114.el6.x86_64 (0x1aa9fd0)>, -14336), (<YumAvailablePackageSqlite : samba-client-3.5.6-86.el6_1.4.x86_64 (0x1aa9dd0)>, -14336), (<YumAvailablePackageSqlite : samba-client-3.5.6-86.el6.x86_64 (0x1aa9e10)>, -14336), (<YumAvailablePackageSqlite : samba-client-3.5.4-68.el6_0.2.x86_64 (0x1aa9f10)>, -14336), (<YumAvailablePackageSqlite : samba-client-3.5.4-68.el6_0.1.x86_64 (0x1aa9d10)>, -14336), (<YumAvailablePackageSqlite : samba-client-3.5.4-68.el6.x86_64 (0x1aa97d0)>, -14336)]
TSINFO: Marking samba-client-3.6.9-160.7.el6rhs.x86_64 as install for redhat-storage-server-2.1.1.0-4.el6rhs.noarch
....


redhat-storage-server-2.1.1.0-4.el6rhs.noarch requires: samba
--> Processing Dependency: samba for package: redhat-storage-server-2.1.1.0-4.el6rhs.noarch
Searching pkgSack for dep: samba
Running compare_providers() for [<YumAvailablePackageSqlite : samba4-4.0.0-55.el6.rc4.x86_64 (0x1ba9610)>, <YumAvailablePackageSqlite : samba-3.5.4-68.el6.x86_64 (0x1ba9590)>, <YumAvailablePackageSqlite : samba-3.5.4-68.el6_0.1.x86_64 (0x1ba9750)>, <YumAvailablePackageSqlite : samba-3.5.4-68.el6_0.2.x86_64 (0x1ba9490)>, <YumAvailablePackageSqlite : samba-3.5.6-86.el6.x86_64 (0x1ba95d0)>, <YumAvailablePackageSqlite : samba-3.5.6-86.el6_1.4.x86_64 (0x1ba94d0)>, <YumAvailablePackageSqlite : samba-3.5.10-114.el6.x86_64 (0x1ba9650)>, <YumAvailablePackageSqlite : samba-3.5.10-115.el6_2.x86_64 (0x1ba9510)>, <YumAvailablePackageSqlite : samba-3.5.10-116.el6_2.x86_64 (0x1ba9710)>, <YumAvailablePackageSqlite : samba-3.5.10-125.el6.x86_64 (0x1ba9690)>, <YumAvailablePackageSqlite : samba-3.6.9-151.el6.x86_64 (0x1ba96d0)>, <YumAvailablePackageSqlite : samba-3.6.9-151.el6_4.1.x86_64 (0x1ba9550)>, <YumAvailablePackageSqlite : samba-3.6.9-160.3.el6rhs.x86_64 (0x1ba93d0)>, <YumAvailablePackageSqlite : samba-3.6.9-160.5.el6rhs.x86_64 (0x1ba9410)>, <YumAvailablePackageSqlite : samba-3.6.9-160.6.el6rhs.x86_64 (0x1ba9310)>, <YumAvailablePackageSqlite : samba-3.6.9-160.7.el6rhs.x86_64 (0x1ba9450)>]
....
Best Order: [(<YumAvailablePackageSqlite : samba4-4.0.0-55.el6.rc4.x86_64 (0x1ba9610)>, 995), (<YumAvailablePackageSqlite : samba-3.6.9-160.7.el6rhs.x86_64 (0x1ba9450)>, 0), (<YumAvailablePackageSqlite : samba-3.6.9-160.6.el6rhs.x86_64 (0x1ba9310)>, -15360), (<YumAvailablePackageSqlite : samba-3.6.9-160.5.el6rhs.x86_64 (0x1ba9410)>, -15360), (<YumAvailablePackageSqlite : samba-3.6.9-160.3.el6rhs.x86_64 (0x1ba93d0)>, -15360), (<YumAvailablePackageSqlite : samba-3.6.9-151.el6_4.1.x86_64 (0x1ba9550)>, -15360), (<YumAvailablePackageSqlite : samba-3.6.9-151.el6.x86_64 (0x1ba96d0)>, -15360), (<YumAvailablePackageSqlite : samba-3.5.10-125.el6.x86_64 (0x1ba9690)>, -15360), (<YumAvailablePackageSqlite : samba-3.5.10-116.el6_2.x86_64 (0x1ba9710)>, -15360), (<YumAvailablePackageSqlite : samba-3.5.10-115.el6_2.x86_64 (0x1ba9510)>, -15360), (<YumAvailablePackageSqlite : samba-3.5.10-114.el6.x86_64 (0x1ba9650)>, -15360), (<YumAvailablePackageSqlite : samba-3.5.6-86.el6_1.4.x86_64 (0x1ba94d0)>, -15360), (<YumAvailablePackageSqlite : samba-3.5.6-86.el6.x86_64 (0x1ba95d0)>, -15360), (<YumAvailablePackageSqlite : samba-3.5.4-68.el6_0.2.x86_64 (0x1ba9490)>, -15360), (<YumAvailablePackageSqlite : samba-3.5.4-68.el6_0.1.x86_64 (0x1ba9750)>, -15360), (<YumAvailablePackageSqlite : samba-3.5.4-68.el6.x86_64 (0x1ba9590)>, -15360)]
TSINFO: Marking samba4-4.0.0-55.el6.rc4.x86_64 as install for redhat-storage-server-2.1.1.0-4.el6rhs.noarch
....
---> Package samba4.x86_64 0:4.0.0-55.el6.rc4 will be installed
Checking deps for samba4.x86_64 0:4.0.0-55.el6.rc4 - u
....
samba4-4.0.0-55.el6.rc4.x86_64 requires: samba4-common = 4.0.0-55.el6.rc4
--> Processing Dependency: samba4-common = 4.0.0-55.el6.rc4 for package: samba4-4.0.0-55.el6.rc4.x86_64
Searching pkgSack for dep: samba4-common
TSINFO: Marking samba4-common-4.0.0-55.el6.rc4.x86_64 as install for samba4-4.0.0-55.el6.rc4.x86_64
....
--> Processing Conflict: samba4-4.0.0-55.el6.rc4.x86_64 conflicts samba < 3.9.9
....
samba4 conflicts with samba-3.6.9-160.7.el6rhs.x86_64
....
--> Processing Conflict: samba4-common-4.0.0-55.el6.rc4.x86_64 conflicts samba-common < 3.9.9
....
samba4-common conflicts with samba-common-3.6.9-160.7.el6rhs.x86_64
--> Finished Dependency Resolution
Dependency Process ending
SKIPBROKEN: samba4-4.0.0-55.el6.rc4.x86_64 from rhel-x86_64-server-6.4.z has depsolving problems
SKIPBROKEN:  --> samba4 conflicts with samba-3.6.9-160.7.el6rhs.x86_64
SKIPBROKEN: samba4-common-4.0.0-55.el6.rc4.x86_64 from rhel-x86_64-server-6.4.z has depsolving problems
SKIPBROKEN:  --> samba4-common conflicts with samba-common-3.6.9-160.7.el6rhs.x86_64
Depsolve time: 8.620
Error: samba4-common conflicts with samba-common-3.6.9-160.7.el6rhs.x86_64
Error: samba4 conflicts with samba-3.6.9-160.7.el6rhs.x86_64
-----------------------------------------------------

So, in summary, we need to mark the < 4 requirement for samba as well in the 'requires' for redhat-storage-server, just as was done for samba-client.

Requires: samba-client < 4

The BZ fails to qualify, hence moving it back to 'ASSIGNED'.
Comment 16 Bala.FA 2013-11-14 03:56:48 EST
fix is under review at https://code.engineering.redhat.com/gerrit/15685
Comment 17 Rejy M Cyriac 2013-11-14 11:57:47 EST
Verified that RHS install, through RH Satellite server, using the redhat-storage-server package (redhat-storage-server-2.1.1.0-5.el6rhs) , now completes successfully.
Comment 18 errata-xmlrpc 2013-11-27 10:47:25 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1769.html

Note You need to log in before you can comment on or make changes to this bug.