Bug 1029306 - Could not create sinatra-example quickstart with ruby-1.8 cartridge successfully
Could not create sinatra-example quickstart with ruby-1.8 cartridge successfully
Status: CLOSED DUPLICATE of bug 1025713
Product: OpenShift Online
Classification: Red Hat
Component: Templates (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Michal Fojtik
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-12 01:29 EST by Wei Sun
Modified: 2015-05-14 22:26 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-12 06:21:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wei Sun 2013-11-12 01:29:50 EST
Description of problem:
Try to create sinatra-example with ruby-1.8 cartridge ,but failed.

There are some error messages:
The initial build for the application failed: Shell command '/sbin/runuser -s /bin/sh 5281c37abc2907c21c0005b4 -c
"exec /usr/bin/runcon 'unconfined_u:system_r:openshift_t:s0:c0,c1002' /bin/sh -c \"gear postreceive --init >>
/tmp/initial-build.log 2>&1\""' returned an error. rc=255

Version-Release number of selected component (if applicable):
https://github.com/openshift/sinatra-example
devenv_4018

How reproducible:
Always

Steps to Reproduce:
1.Create sinatra-example with ruby-1.8 cartridge (following:  https://github.com/openshift/sinatra-example)
2.
3.

Actual results:
openshift@openshift-ubuntu:~/test$ rhc app create -a sinatra -t ruby-1.8 --from-code https://github.com/openshift/sinatra-example.git 
Application Options
-------------------
  Domain:      wsundev4018
  Cartridges:  ruby-1.8
  Source Code: https://github.com/openshift/sinatra-example.git
  Gear Size:   default
  Scaling:     no

Creating application 'sinatra' ... 
The initial build for the application failed: Shell command '/sbin/runuser -s /bin/sh 5281c37abc2907c21c0005b4 -c
"exec /usr/bin/runcon 'unconfined_u:system_r:openshift_t:s0:c0,c1002' /bin/sh -c \"gear postreceive --init >>
/tmp/initial-build.log 2>&1\""' returned an error. rc=255

.Last 10 kB of build output:
Stopping Ruby cartridge
httpd (no pid file) not running
Building git ref 'master', commit 5015a34
Building Ruby cartridge
Bundling RubyGems based on Gemfile/Gemfile.lock to repo/vendor/bundle with 'bundle install --deployment'
Could not load OpenSSL.
You must recompile Ruby with OpenSSL support or change the sources in your
Gemfile from 'https' to 'http'. Instructions for compiling with OpenSSL using
RVM are available at rvm.io/packages/openssl.
An error occurred executing 'gear postreceive' (exit code: 17)
Error message: Failed to execute: 'control build' for /var/lib/openshift/5281c37abc2907c21c0005b4/ruby

For more details about the problem, try running the command again with the '--trace' option.


Expected results:
Could create sinatra quickstart with ruby-1.8 cartridge successfully

Additional info:
Could create this quickstart with ruby-1.9 successfully
Comment 1 Michal Fojtik 2013-11-12 06:21:13 EST

*** This bug has been marked as a duplicate of bug 1025713 ***

Note You need to log in before you can comment on or make changes to this bug.