Bug 1029347 - tools-bom doesn't resolve org.jboss.osgi.spi:jbosgi-spi:jar:3.2.0.Final
tools-bom doesn't resolve org.jboss.osgi.spi:jbosgi-spi:jar:3.2.0.Final
Status: VERIFIED
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Quickstarts (Show other bugs)
6.2.0
Unspecified Unspecified
high Severity high
: DR13
: EAP 6.4.0
Assigned To: Romain Pelisse
Nikoleta Ziakova
Russell Dickenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-12 03:44 EST by Lin Gao
Modified: 2014-12-15 03:48 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lin Gao 2013-11-12 03:44:24 EST
Description of problem:


Version-Release number of selected component (if applicable): 6.2.0.CR1


How reproducible:

Run mvn -U org.jboss.maven.plugins:maven-qstools-plugin:1.3.0.Final:bom-check on EAP 6.2.0.CR1 Boms


Steps to Reproduce:
1. Checkout https://github.com/jboss-developer/jboss-eap-boms
2. Change to 6.2.x branch: git checkout 6.2.x 
3. Run: mvn -U org.jboss.maven.plugins:maven-qstools-plugin:1.3.0.Final:bom-check

Actual results:
failed: Unable to collect/resolve dependency tree for a resulution due to: Could not find artifact  org.jboss.osgi.spi:jbosgi-spi:jar:3.2.0.Final

Expected results:
All Dependencies were resolved

Additional info:

The dependency tree of this missing artifact is: 

[INFO] +- org.jboss.as:jboss-as-arquillian-container-managed:jar:7.2.0.Final:compile
[INFO] |  +- org.jboss.as:jboss-as-arquillian-common:jar:7.2.0.Final:compile
[INFO] |  |  +- org.jboss.osgi.spi:jbosgi-spi:jar:3.2.0.Final:compile
...
Comment 1 Lin Gao 2013-11-12 03:51:54 EST
The related bom artifact is: jboss-javaee-6.0-with-tools in jboss-eap-boms(https://github.com/jboss-developer/jboss-eap-boms/blob/6.2.x/jboss-javaee-6.0-with-tools/pom.xml), and I find that there is another jboss-wfk-boms which also contains this artifact: https://github.com/jboss-developer/jboss-wfk-boms/blob/master/jboss-javaee-6.0-with-tools/pom.xml

The content seems the same, shouldn't we keep only one jboss-javaee-6.0-with-tools bom?
Comment 2 Marek Novotny 2013-11-12 05:08:16 EST
No, EAP needs to provide it for its quickstarts and WFK certifies the versions in it so WFK needs to have write access to changing the certified combination of ARQ components.
Comment 3 Pete Muir 2013-11-12 08:28:48 EST
We hope to resolve this in EAP 6.3
Comment 4 Paul Gier 2013-11-12 14:27:27 EST
Added a temporary config to ignore this failure for 6.2
https://github.com/jboss-developer/jboss-eap-boms/commit/b93687558762451fd35150309f3d9e96178d6a53
Comment 6 sgilda 2014-04-11 13:33:07 EDT
This has been idle for a while. Is it supposed to work in JBoss EAP 6.3?
Comment 7 Marek Novotny 2014-04-14 03:07:09 EDT
Reassigning to Paul as I don't maintain EAP6 BOMs
Comment 8 Romain Pelisse 2014-12-05 04:54:01 EST
Hi,

I've tried this again, and it seems to be fixed. Indeed the required deps is available in our repos[1] - assuming this get public released, it should work also upstream.

Out of thoroughness, I've tried with the 3 branches available in the project (6.2.x,6.3.x and 6.4.x) and it worked for all of them.


[1] http://download.eng.bos.redhat.com/brewroot/repos/jb-eap-6.4-rhel-6-build/latest/maven/org/jboss/osgi/spi/jbosgi-spi/3.2.0.Final/
Comment 9 Nikoleta Ziakova 2014-12-15 03:48:21 EST
Verified with EAP 6.4.0.DR13.

Note You need to log in before you can comment on or make changes to this bug.