Bug 1029352 - windows 2008 R2 guest BSOD with '-no-kvm'
windows 2008 R2 guest BSOD with '-no-kvm'
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
7.0
x86_64 Linux
low Severity low
: rc
: ---
Assigned To: Hai Huang
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-12 03:53 EST by Xu Han
Modified: 2013-12-16 10:16 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-16 10:16:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen shot (5.14 KB, image/png)
2013-11-12 03:54 EST, Xu Han
no flags Details

  None (edit)
Description Xu Han 2013-11-12 03:53:48 EST
Description of problem:
windows 2008 R2 guest BSOD with '-no-kvm'

Version-Release number of selected component (if applicable):
qemu-kvm-rhev-1.5.3-18.el7.x86_64

How reproducible:
always

Steps to Reproduce:
1. boot windows 2008 R2 guest with '-no-kvm'
# /usr/libexec/qemu-kvm -nodefaults -M pc -m 4G -cpu Opteron_G3 -smp 4,cores=2,threads=2,sockets=1 -boot menu=on -monitor stdio -rtc base=localtime,clock=host,driftfix=slew -qmp tcp:0:5555,server,nowait -vga qxl -drive file=/home/win2008r2.qcow2_v3,format=qcow2,id=guest-img,if=none,werror=stop,rerror=stop -device ide-hd,drive=guest-img,id=os-disk -spice disable-ticketing,port=5931 -no-kvm

Actual results:
BSOD

Expected results:
guest can boot success

Additional info:
Comment 1 Xu Han 2013-11-12 03:54:22 EST
Created attachment 822785 [details]
screen shot
Comment 5 Ronen Hod 2013-12-02 11:04:25 EST
Paolo,
What is your call?
Comment 6 Paolo Bonzini 2013-12-02 11:15:03 EST
Not a bug.
Comment 7 Ronen Hod 2013-12-02 12:12:56 EST
Paolo, How comes?
It should be fixable.
Are you saying that it is not needed? Could be, but it doesn't look good.
Can it happen to an innocent Libvirt user?
Comment 8 Paolo Bonzini 2013-12-03 04:52:43 EST
More precisely, not a bug as far as we are concerned.  We do not support TCG except for the very specific case of running libguestfs, I think?

It is fixable, but I have no idea whether it is easy or hard because I have no experience.

It can happen if you use 'qemu' instead of 'kvm' as the virtualization technology.  Perhaps we should add a "taint" flag to libvirt for domains that are not running under KVM and have qemu-kvm in the emulator name.

Note You need to log in before you can comment on or make changes to this bug.