Bug 1029385 - lack of non-ascii support
lack of non-ascii support
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: util-linux (Show other bugs)
7.0
Unspecified Unspecified
low Severity medium
: rc
: ---
Assigned To: Karel Zak
qe-baseos-daemons
:
Depends On:
Blocks: 1289485 1313485
  Show dependency treegraph
 
Reported: 2013-11-12 05:25 EST by Karel Volný
Modified: 2016-11-03 17:24 EDT (History)
6 users (show)

See Also:
Fixed In Version: util-linux-2.23.2-30.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-03 17:24:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of the problem (81.52 KB, image/png)
2013-11-12 05:25 EST, Karel Volný
no flags Details
new screenshot (71.86 KB, image/png)
2015-01-07 11:11 EST, Karel Volný
no flags Details
before the fix (17.04 KB, image/png)
2016-09-27 07:40 EDT, Karel Volný
no flags Details
after the fix (17.65 KB, image/png)
2016-09-27 07:41 EDT, Karel Volný
no flags Details

  None (edit)
Description Karel Volný 2013-11-12 05:25:53 EST
Created attachment 822812 [details]
screenshot of the problem

Description of problem:
The default console font is not able to display all the needed characters.

Version-Release number of selected component (if applicable):
kbd-misc-1.15.5-7.el7.noarch

How reproducible:
always

Steps to Reproduce:
1. I tried to boot in rescue mode (removing "rhgb", "quiet", adding "single")

Actual results:
see the screenshot - at the bottom there is sentence
"Pro zah?jen? ?dr?by je t?eba zadat heslo u?ivatele root"

Expected results:
it should be
"Pro zahájení údržby je třeba zadat heslo uživatele root"

Additional info:
I'm not sure if this is problem of the font itself or some console translation, as after logging in, I'm getting squares instead of some characters, not the question marks as in the screenshot ...?
Comment 2 Vitezslav Crhonek 2013-11-18 09:09:51 EST
The default console font is "latarcyrheb-sun16" as far as I know and it should be able to display all needed characters.

This font is shipped within kbd, but I do not know which component is responsible to set it in this phase of booting.

You can do it manually with "setfont latarcyrheb-sun16" command.
Comment 3 RHEL Product and Program Management 2014-03-22 02:32:53 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 4 Karel Volný 2015-01-07 11:11:17 EST
Created attachment 977431 [details]
new screenshot

(In reply to Vitezslav Crhonek from comment #2)
> This font is shipped within kbd, but I do not know which component is
> responsible to set it in this phase of booting.

now the question is ... is _anything_ actually trying to to set it in this phase?

I'd say it should be systemd-vconsole-setup.service which is required by sysinit.target which is required by rescue.target which is reached before the password prompt ...

FTR, the problem still persists with RHEL-7.1-20150107.n.0 - and in addition, there are some random characters scattered all over the screen
Comment 6 Vitezslav Crhonek 2015-04-22 06:13:54 EDT
This should be reassigned to different component, which is responsible for setting correct font, keymap, etc. when booting to rescue mode. I don't know for sure which one is it.

kbd is just a bunch of fonts, keymaps and tools for setting them, but it has no logic in it, it's supposed to be called by other programs and scripts. And it contains fonts with non-ascii support.

Changing component to systemd as Karel suggested in comment#4. Feel free to change it again, if it's wrong component.
Comment 7 Jan Synacek 2015-06-30 09:05:15 EDT
This problem is probably two different problems.

First one is that the font specified in /etc/vconsole.conf is not loaded at all. That can be verified by executing "loadkeys cz" and then typing the first row on the keyboard. But, even after the font has been loaded, the message is still not displayed properly.
The second problem is the actual display of the message.

The service that I have created to do the font setting is posted below. For some reason, modifying systemd-vconsole-setup to be run before rescue.target didn't work.

# systemctl cat vconsole-workaround.service 
# /etc/systemd/system/vconsole-workaround.service
[Unit]
Description=vconsole workaround
Before=rescue.target

[Service]
Type=oneshot
RemainAfterExit=yes
ExecStart=/usr/bin/setfont latarcyrheb-sun16

[Install]
WantedBy=rescue.target
Comment 9 Jan Synacek 2015-07-02 10:21:40 EDT
There is probably something wrong with how sulogin handles the output (and perhaps even the terminal):

# LANG=cs_CZ.UTF-8 gettext -e util-linux "Give root password for maintenance\n"
Pro zahájení údržby je třeba zadat heslo uživatele root

# LANG=cs_CZ.UTF-8 gettext -e util-linux "(or press Control-D to continue): "
(nebo stiskněte Control-D, abyste pokračovali): 

# LANG=cs_CZ.UTF-8 sulogin 
Pro zah?jen? ?dr?by stiskn?te Enter(nebo stiskn?te Control-D, abyste pokra?ovali):
Comment 10 Karel Zak 2015-08-26 08:13:05 EDT
(In reply to Jan Synacek from comment #9)
> # LANG=cs_CZ.UTF-8 sulogin 
> Pro zah?jen? ?dr?by stiskn?te Enter(nebo stiskn?te Control-D, abyste
> pokra?ovali):

Well, you cannot do that with programs like agetty or sulogin on pseudo-terminals. If you try the same command on regular console that all will work as expected.

Anyway, the problem is how sulogin detects virtual console, the problem is fixed in the current upstream tree (I'm not able to reproduce it with sulogin from v2.27). The best will be to rebase sulogin.c to the latest upstream, we have more fixes there.
Comment 12 Tomas Dolezal 2015-09-01 05:07:41 EDT
CC myself & severity to medium - this impacts remote debugging if user cannot read console errors in their native tongue.
Comment 14 Mike McCune 2016-03-28 18:54:17 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 18 Karel Volný 2016-09-27 07:40 EDT
Created attachment 1205173 [details]
before the fix
Comment 19 Karel Volný 2016-09-27 07:41 EDT
Created attachment 1205174 [details]
after the fix
Comment 22 errata-xmlrpc 2016-11-03 17:24:31 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHSA-2016-2605.html

Note You need to log in before you can comment on or make changes to this bug.