Bug 10294 - folded collating sequence for en_US
Summary: folded collating sequence for en_US
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc   
(Show other bugs)
Version: 6.1
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-03-22 03:23 UTC by michal
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-22 14:52:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description michal 2000-03-22 03:23:25 UTC
At least on Alpha, but maybe also on other platoform a collating
sequence supplied in /usr/share/locale/en_US/LC_COLLATE
seems to fold upper and lower case thus rendering sorting utilities
rather ineffective.  The reason I suspect that is that in order to
restore some sanity in sort one has to unset both LANG and LC_ALL
environment variables.  If at least one of these is set to en_US
then sort colapses.

Curiously enough 'ls' also appears to consult LC_COLLATE if one
of variables above is set but it is not affected by this bogosity.

  Nichal Jaegermann
  michal@harddata.com

Comment 1 Bill Nottingham 2000-03-22 14:49:59 UTC
(changed to all platforms, it affects all of them)

Comment 2 Cristian Gafton 2000-05-22 14:52:59 UTC
assign to jakub

Comment 3 Jakub Jelinek 2000-09-04 15:47:48 UTC
That's how en_US collation should look like (the case of characters matters
only when the strings are equal in case insensitive comparison).
Basically, if you want ASCII sorting, use POSIX/C locale, if you want the
sorting people have been doing for centuries, use your locale.
ls is still using strcmp while it should use strcoll, it will be changed
in the future.


Note You need to log in before you can comment on or make changes to this bug.