Bug 1029439 - SELinux is preventing /usr/libexec/ibus-x11 from 'execute' accesses on the file /usr/lib64/gtk-2.0/modules/libpk-gtk-module.so.
SELinux is preventing /usr/libexec/ibus-x11 from 'execute' accesses on the fi...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:b9a7b83294dae01b9cbed906b14...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-12 06:51 EST by Jorge
Modified: 2013-11-12 08:49 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-12 08:49:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jorge 2013-11-12 06:51:54 EST
Description of problem:
SELinux is preventing /usr/libexec/ibus-x11 from 'execute' accesses on the file /usr/lib64/gtk-2.0/modules/libpk-gtk-module.so.

*****  Plugin restorecon (99.5 confidence) suggests  *************************

If you want to fix the label. 
/usr/lib64/gtk-2.0/modules/libpk-gtk-module.so default label should be lib_t.
Then you can run restorecon.
Do
# /sbin/restorecon -v /usr/lib64/gtk-2.0/modules/libpk-gtk-module.so

*****  Plugin catchall (1.49 confidence) suggests  ***************************

If you believe that ibus-x11 should be allowed execute access on the libpk-gtk-module.so file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep ibus-x11 /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Context                unconfined_u:object_r:data_home_t:s0
Target Objects                /usr/lib64/gtk-2.0/modules/libpk-gtk-module.so [
                              file ]
Source                        ibus-x11
Source Path                   /usr/libexec/ibus-x11
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           ibus-1.5.4-1.fc19.x86_64
Target RPM Packages           PackageKit-gtk3-module-0.8.9-6.fc19.x86_64
Policy RPM                    selinux-policy-3.12.1-74.11.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.11.7-200.fc19.x86_64 #1 SMP Mon
                              Nov 4 14:09:03 UTC 2013 x86_64 x86_64
Alert Count                   3
First Seen                    2013-11-11 18:37:20 CET
Last Seen                     2013-11-12 12:44:37 CET
Local ID                      7a7577a0-8a53-4b36-889e-b43f4fab59c3

Raw Audit Messages
type=AVC msg=audit(1384256677.633:494): avc:  denied  { execute } for  pid=1558 comm="ibus-x11" path="/usr/lib64/gtk-2.0/modules/libpk-gtk-module.so" dev="sda6" ino=7606767 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:data_home_t:s0 tclass=file


type=SYSCALL msg=audit(1384256677.633:494): arch=x86_64 syscall=mmap success=no exit=EACCES a0=0 a1=2031c8 a2=5 a3=802 items=0 ppid=1 pid=1558 auid=4294967295 uid=42 gid=42 euid=42 suid=42 fsuid=42 egid=42 sgid=42 fsgid=42 ses=4294967295 tty=(none) comm=ibus-x11 exe=/usr/libexec/ibus-x11 subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 key=(null)

Hash: ibus-x11,xdm_t,data_home_t,file,execute

Additional info:
reporter:       libreport-2.1.9
hashmarkername: setroubleshoot
kernel:         3.11.7-200.fc19.x86_64
type:           libreport
Comment 1 Daniel Walsh 2013-11-12 08:49:50 EST
Did you read the alert?  It told you what to do.


If you want to fix the label. 
/usr/lib64/gtk-2.0/modules/libpk-gtk-module.so default label should be lib_t.
Then you can run restorecon.
Do
# /sbin/restorecon -v /usr/lib64/gtk-2.0/modules/libpk-gtk-module.so


It looks like this file was created in your homedir and then mv'd to /usr/lib64/...

Note You need to log in before you can comment on or make changes to this bug.