Bug 1029443 - quota: for pre-existing data, the alerts(soft-limit) are not found in logs
quota: for pre-existing data, the alerts(soft-limit) are not found in logs
Status: CLOSED NOTABUG
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: quota (Show other bugs)
2.1
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Vijaikumar Mallikarjuna
storage-qa-internal@redhat.com
:
Depends On:
Blocks: 1202289 1265532
  Show dependency treegraph
 
Reported: 2013-11-12 07:02 EST by Saurabh
Modified: 2016-09-17 08:37 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1202289 (view as bug list)
Environment:
Last Closed: 2015-11-17 03:52:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Saurabh 2013-11-12 07:02:14 EST
Description of problem:
Could not see the alert messages in the intended logs.
This issue is seen with pre-existing data and then setting quota limit on that directory.

Version-Release number of selected component (if applicable):
glusterfs-3.4.0.43rhs-1

How reproducible:
always

Steps to Reproduce:
1. create a volume, start the volume, enable quota
2. mount over nfs or glusterfs
3. mkdir dir
4. create data inside the dir, say upto 100GB
5. set quota limit on dir, say 100GB its

Actual results:
alert message about soft-limit is not seen in the logs.


Expected results:
alerts should be generated if limit crosses the soft-limit %age

Additional info:
Though after limit is reached and trying to create more data, sends disk quota exceeded
Comment 2 Vijaikumar Mallikarjuna 2015-03-16 06:05:40 EDT
Testcase ./tests/bugs/quota/bug-1087198.t is failing because sometimes 'Usage crossed soft limit' alert message is not generated in the log.
Comment 3 Vijaikumar Mallikarjuna 2015-08-06 06:07:31 EDT
This is an expected behavior, as alert logs are generated only when there is an IO happening.
For a existing data, when quota is enabled, alert logs will not be generated if the existing data already crossed quota limit.
Comment 4 Vijaikumar Mallikarjuna 2015-11-17 03:52:50 EST
This is an expected behavior, so closing bug.

Note You need to log in before you can comment on or make changes to this bug.