Bug 1029449 - add createInitialBundleVersionViaContentHandle to BundleManager
add createInitialBundleVersionViaContentHandle to BundleManager
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Provisioning (Show other bugs)
JON 3.2
Unspecified Unspecified
unspecified Severity unspecified
: ER07
: JON 3.2.0
Assigned To: Thomas Segismont
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-12 07:16 EST by Libor Zoubek
Modified: 2015-11-01 19:43 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Libor Zoubek 2013-11-12 07:16:49 EST
Description of problem:

Within BundleManger there are methods : createBundle* using different ways. ViaFileHandle, ViaURL, ViaByteArray, ViaFile. Each of this method has a "duplicit" method called createInitialBundle*. This duplicity exists because of new bundle permissions and bundle groups and allows assigning new bundle to group on create time.

Method createInitialBundleVersionViaFileHandle is missing, I think it should be added.


Version-Release number of selected component (if applicable):
JON 3.2.ER5
Comment 1 Mike Foley 2013-11-12 09:22:54 EST
PM-222
Comment 2 Thomas Segismont 2013-11-14 09:33:35 EST
Fixed in master

commit 439aa8447379617eb36f6a5bc9073ec51633a69c
Author: Thomas Segismont <tsegismo@redhat.com>
Date:   Thu Nov 14 15:32:40 2013 +0100
Comment 3 Thomas Segismont 2013-11-14 09:35:07 EST
Cherry-picked to release/jon3.2.x

commit 535e6c93c80ef38a56a55eaf1d3a189d51a1240f
Author: Thomas Segismont <tsegismo@redhat.com>
Date:   Thu Nov 14 15:32:40 2013 +0100
Comment 4 Simeon Pinder 2013-11-19 10:48:18 EST
Moving to ON_QA as available for testing with new brew build.
Comment 5 Simeon Pinder 2013-11-22 00:13:47 EST
Mass moving all of these from ER6 to target milestone ER07 since the ER6 build was bad and QE was halted for the same reason.
Comment 6 Libor Zoubek 2013-11-25 04:40:48 EST
verified on ER07

Note You need to log in before you can comment on or make changes to this bug.