Bug 1029452 - [RHSC] After starting remove-brick on a volume, clicking on the activities icon shows all menu items enabled.
[RHSC] After starting remove-brick on a volume, clicking on the activities ic...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
Unspecified Unspecified
high Severity high
: ---
: RHGS 2.1.2
Assigned To: anmol babu
Shruti Sampat
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-12 07:22 EST by Shruti Sampat
Modified: 2015-05-13 12:28 EDT (History)
8 users (show)

See Also:
Fixed In Version: cb8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-25 03:03:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (126.76 KB, image/png)
2013-11-12 07:23 EST, Shruti Sampat
no flags Details
engine logs (1.58 MB, text/x-log)
2013-11-12 07:24 EST, Shruti Sampat
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 21259 None None None Never

  None (edit)
Description Shruti Sampat 2013-11-12 07:22:09 EST
Description of problem:
-----------------------
After starting remove-brick on a volume, after the remove-brick icon appears in the Activities column, on clicking on the menu beside the icon shows all the menu items as enabled. Ideally, status and stop items should be enabled, and commit and retain should be disabled.

Version-Release number of selected component (if applicable):
Red Hat Storage Console Version: 2.1.2-0.23.master.el6_5 

How reproducible:
Intermittent

Steps to Reproduce:
1. Start remove brick operation on a volume, and wait for the icon to appear.
2. Once the icon appears, click on the menu beside the icon.
3. It is seen that all the menu items are enabled. Click on Commit.

Actual results:
Clicking on commit shows a confirmation dialog, asking if the user is sure that these bricks should be committed, but the bricks are not listed. It is not possible to close this dialog. Reloading the page causes the dialog to disappear. After reloading the page, the correct menu items were enabled.

Expected results:
On clicking on the menu beside the remove-brick icon, only menu items status and stop should be enabled, while data migration is in progress.

Additional info:
See attached screenshot for the empty commit dialog.
Comment 1 Shruti Sampat 2013-11-12 07:23:55 EST
Created attachment 822901 [details]
screenshot
Comment 2 Shruti Sampat 2013-11-12 07:24:28 EST
Created attachment 822902 [details]
engine logs
Comment 4 Shruti Sampat 2013-11-19 04:26:13 EST
Could you please explain what the fix is or add the link to the fix?
Comment 5 Shruti Sampat 2013-11-19 04:42:10 EST
Verified as fixed in Red Hat Storage Console Version: 2.1.2-0.24.master.el6_5. 
After remove-brick start, Status and Stop are enabled, Commit and Retain are disabled.
Comment 7 errata-xmlrpc 2014-02-25 03:03:01 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0208.html

Note You need to log in before you can comment on or make changes to this bug.