Bug 1029458 - xfs_check deprecation
xfs_check deprecation
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: xfsprogs (Show other bugs)
7.0
All Linux
medium Severity medium
: rc
: ---
Assigned To: Eric Sandeen
Boris Ranto
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-12 07:34 EST by Karel Volný
Modified: 2014-06-18 00:55 EDT (History)
2 users (show)

See Also:
Fixed In Version: xfsprogs-3.2.0-0.7.alpha1.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 08:04:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karel Volný 2013-11-12 07:34:12 EST
Description of problem:
xfs_check is about to be deprecated and should be (fully?) replaced by xfs_repair

IMHO we should remove xfs_check from RHEL7 before the release - once it gets in, we will have to support it for the lifecycle of RHEL7 which should span long after the upstream drops support

Version-Release number of selected component (if applicable):
xfsprogs-3.2.0-0.1.alpha1.el7

How reproducible:
always

Steps to Reproduce:
0. yum install -y xfsprogs
1. xfs_check

Actual results:
xfs_check is deprecated and scheduled for removal in June 2014.
Please use xfs_repair -n <dev> instead.
Usage: xfs_check [-fsvV] [-l logdev] [-i ino]... [.b bno].. special

Expected results:
bash: xfs_check: No such file or directory

Additional info:
Comment 2 Eric Sandeen 2013-11-12 12:21:07 EST
Agreed, I'm happy to remove it now.

Thanks,
-Eric
Comment 4 Boris Ranto 2014-01-03 06:00:39 EST
Hi Eric,

the man page for xfs_check is still a part of the xfsprogs package:

[root@lenovo-rd230-01 ~]# rpm -ql xfsprogs |grep xfs_check
/usr/share/man/man8/xfs_check.8.gz

Is this intentional or just an overlook?
Comment 5 Eric Sandeen 2014-01-03 13:13:19 EST
It's an oversight.  :(

+# xfs_check is deprecated; nuke it from orbit for RHEL7
+rm -f $RPM_BUILD_ROOT/%{_sbindir}/xfs_check
+rm -f $RPM_BUILD_ROOT/%{_mandir}/man8/xfs_check.8.gz

Maybe the *.gz doesn't exist here yet, at the point that it was rm -f'd.  (I probably should have left out the "-f").
Comment 6 Eric Sandeen 2014-01-03 13:38:38 EST
Strange, when I rebuild the RPM, the manpage is not present:

# rpm -qpl /root/rpmbuild/RPMS/x86_64/xfsprogs-3.2.0-0.4.alpha2.el6.x86_64.rpm | grep check
/usr/sbin/xfs_ncheck
/usr/share/man/man8/xfs_ncheck.8.gz
#
Comment 8 Boris Ranto 2014-02-25 10:02:44 EST
This probably should not be in ON_QA, The man page is still there in the most recent xfsprogs package (3.2.0-0.6.alpha2.el7) although the manual rebuild produced xfs_check-man-page-free build.

I though the reason might be that the make command in spec file does not override the PKG_MAN_DIR variable but the koji scratch build with PKG_MAN_DIR=%{_mandir} still produced an xfsprogs package with xfs_check man page.

Looking at the build log, the command for removal is there and the path for removal seems to be correct. The only thing that comes in mind is that the command is run after the files are packaged but it does not make sense since the xfs_check binary is removed just before the man page and it is not a part of the resulting xfsprogs rpm. Maybe, this is a koji bug? If that is the case, then we could probably move this bz to verified.
Comment 9 Eric Sandeen 2014-02-25 11:17:15 EST
Ok, let's move this back to assigned and I'll fix it up.  I'll remove <path>/man8/xfs_check* - that seems to work.

-Eric
Comment 10 Eric Sandeen 2014-02-25 12:01:42 EST
Ok, I need blocker to be abel to fix this, I guess.
Comment 11 Boris Ranto 2014-03-04 05:09:21 EST
Verified in xfsprogs-3.2.0-0.8.alpha2.el7. Both xfs_check binary as well as man page are no longer present in the xfsprogs package.
Comment 12 Ludek Smid 2014-06-13 08:04:11 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.