Bug 1029484 - [RHSC] Rename the 'Stop Rebalance' button in the rebalance status dialog to 'Stop'
[RHSC] Rename the 'Stop Rebalance' button in the rebalance status dialog to '...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
Unspecified Unspecified
low Severity low
: ---
: RHGS 3.1.0
Assigned To: Karnan
Shruti Sampat
: Reopened
Depends On:
Blocks: 1202842
  Show dependency treegraph
 
Reported: 2013-11-12 08:11 EST by Shruti Sampat
Modified: 2016-11-13 19:04 EST (History)
9 users (show)

See Also:
Fixed In Version: rhsc-3.1.0-57
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-07-29 01:25:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rebalance-status screenshot (112.58 KB, image/png)
2013-11-13 01:10 EST, Shruti Sampat
no flags Details
remove-brick-status screenshot (114.38 KB, image/png)
2013-11-13 01:11 EST, Shruti Sampat
no flags Details
Attaching the screenshot for the rebalance status dialog where the button is present (185.41 KB, image/png)
2015-05-27 07:52 EDT, RamaKasturi
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 28471 master MERGED webadmin: Volume rebalance status popup button caption changed Never

  None (edit)
Description Shruti Sampat 2013-11-12 08:11:46 EST
Description of problem:
-----------------------
The 'stop rebalance' button in the rebalance status dialog should be renamed to simply 'stop'

Version-Release number of selected component (if applicable):
Red Hat Storage Console Version: 2.1.2-0.23.master.el6_5 

How reproducible:
Always

Steps to Reproduce:
1. start rebalance on a volume and open the rebalance status dialog

Actual results:
The 'Stop Rebalance' button is seen.

Expected results:
The button to stop rebalance should be called simply 'Stop'

Additional info:
Comment 2 Dusmant 2013-11-12 08:41:07 EST
It's not a bug. This is, what was decided for this screen.
Comment 3 Shruti Sampat 2013-11-13 01:09:50 EST
Dusmant,

The change described in this bug is required, inorder to be consistent with the remove-brick status dialog. See screenshots of both dialogs attached. In the rebalance dialog, the button to stop rebalance is called 'Stop Rebalance' and in remove-brick status dialog, the button to stop the operation is called simply 'Stop'. Another point is that while one is looking at the rebalance status dialog, it should be sufficient to say 'stop' instead of 'stop rebalance'. IMO, it should be fixed.
Comment 4 Shruti Sampat 2013-11-13 01:10:30 EST
Created attachment 823251 [details]
rebalance-status screenshot
Comment 5 Shruti Sampat 2013-11-13 01:11:19 EST
Created attachment 823252 [details]
remove-brick-status screenshot
Comment 6 RamaKasturi 2015-05-27 07:51:17 EDT
Verified and works fine with build rhsc-3.1.0-0.57.master.el6.noarch.

StopRebalance button in the Rebalance status dialog has been renamed to 'stop'. Attaching the screenshot.
Comment 7 RamaKasturi 2015-05-27 07:52:23 EDT
Created attachment 1030501 [details]
Attaching the screenshot for the rebalance status dialog where the button is present
Comment 9 errata-xmlrpc 2015-07-29 01:25:05 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-1494.html

Note You need to log in before you can comment on or make changes to this bug.