Bug 1029492 - AFR: change one file in one brick,prompt "[READ ERRORS]" when open it in the client
AFR: change one file in one brick,prompt "[READ ERRORS]" when open it in the ...
Status: CLOSED NOTABUG
Product: GlusterFS
Classification: Community
Component: replicate (Show other bugs)
3.4.1
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Pranith Kumar K
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-12 08:28 EST by huangchongyuan
Modified: 2014-01-03 03:51 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-03 03:51:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description huangchongyuan 2013-11-12 08:28:59 EST
Description of problem:
AFR volume: change a file in one brick,execute "gluster volume heal afr_vol full"(actuclly,it doesnot work).open this file in the client,prompt "[READ ERRORS]".

Version-Release number of selected component (if applicable):
3.4.1 & 3.3.2

How reproducible:
always and i have test many times.

Steps to Reproduce:
1.create a afr volume: gluster volume create afr_vol replica 3 192.168.8.{80,81,82}:/mnt/sdb1
2.started it: gluster volume start afr_vol
3.change one file in 192.168.8.80:/mnt/sdb1 (just add a row or delete a row)
4.execute heal:gluster volume heal afr_vol full(it doesnot work and you can see from 8.80:/mnt/sdb1)
5.open this file (used 'vim')

Actual results:
prompt "[READ ERRORS]"

Expected results:
open file normally

Additional info:
"volume heal Volume_name full" doesnot work and I have test many times.
Comment 1 Pranith Kumar K 2014-01-03 03:51:14 EST
File should not be modified in the brick directly. Marking it as not a bug.

Note You need to log in before you can comment on or make changes to this bug.