Bug 1029494 - Document: Add warning not to copy HornetQ journal files among servers in cluster
Document: Add warning not to copy HornetQ journal files among servers in cluster
Status: CLOSED DUPLICATE of bug 1089298
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Documentation (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Nidhi
Russell Dickenson
: Documentation, FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-12 08:32 EST by Miroslav Novak
Modified: 2014-08-14 11:18 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-04 06:35:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miroslav Novak 2013-11-12 08:32:20 EST
Description of problem:
If HornetQ journal is copied from one server to another and started then warning:

WARN  [org.hornetq.core.cluster.impl.DiscoveryGroupImpl] (hornetq-discovery-group-thread-dg-group1) There are more than one servers on the network broadcasting the same node id. You will see this message exactly once (per node) if a node is restarted, in which case it can be safely ignored. But if it is logged continuously it means you really do have more than one node on the same network active concurrently with the same node id. This could occur if you have a backup node active at the same time as its live node. nodeID=630c8f17-3ee0-11e2-b591-cffd2592f65e

is printed to log. This is because HornetQ generates unique id during first start of server and is stored in journal. When this journal is copied to another server and configured to form (HornetQ) cluster with original server then there are two servers with the same id.
Comment 2 Miroslav Novak 2014-08-04 06:29:36 EDT
Hi Nidhi,

yes, this information is enough. This bz can be closed.

Thanks, 
Mirek
Comment 4 Nidhi 2014-08-04 06:37:30 EDT

*** This bug has been marked as a duplicate of bug 1089298 ***

Note You need to log in before you can comment on or make changes to this bug.