Bug 1029496 - AFR: lose files in one node, "ls" failed in the client, but open normally
AFR: lose files in one node, "ls" failed in the client, but open normally
Status: CLOSED NOTABUG
Product: GlusterFS
Classification: Community
Component: replicate (Show other bugs)
3.4.1
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Pranith Kumar K
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-12 08:43 EST by huangchongyuan
Modified: 2014-01-03 03:53 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-03 03:53:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description huangchongyuan 2013-11-12 08:43:14 EST
Description of problem:
AFR volume: create a afr volume. delete a file in brick(default node:system get metadata from this node),"ls" failed in client,but open normally.

Version-Release number of selected component (if applicable):
3.4.1 & 3.3.2

How reproducible:
only delete file in special node (default node)

Steps to Reproduce:
1.create a afr volume 
2.delete a file in default node(system get metadata from this node)
3."ls" in client

Actual results:
cannot show this file,but can use it normally. And it can trigger heal.

Expected results:
show this file

Additional info:
Comment 1 Pranith Kumar K 2014-01-03 03:53:28 EST
Bricks are not allowed to be modified directly. Marking this as not a bug.

Note You need to log in before you can comment on or make changes to this bug.