Bug 10295 - incorrect lsdev display
Summary: incorrect lsdev display
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: procinfo   
(Show other bugs)
Version: 6.1
Hardware: alpha
OS: Linux
medium
low
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-03-22 03:34 UTC by michal
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-03 09:24:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description michal 2000-03-22 03:34:16 UTC
Due to parsing errors at least on Alpha lsdev makes a difference
between strings like " eth0" and "eth0" and makes a display rather
funny.  I have seen in the past also errors on other platforms
which had an information in /proc in a slightly different format
than what the author of this utility had on hands.

The author was notified about that over a year ago, and supplied
with fixes, but unfortunately he seems to have very vague ideas
about how to write something in Perl.  Sigh!  At least he could
pay attention to complaints from 'perl -cw'.

  Michal Jaegermann
  michal@harddata.com

Comment 1 Bernhard Rosenkraenzer 2000-08-03 09:24:16 UTC
If you have those patches, please attach them so we don't have to redo them...


Comment 2 Bernhard Rosenkraenzer 2000-11-16 12:42:26 UTC
Fixed in procinfo-17-10


Note You need to log in before you can comment on or make changes to this bug.