Bug 1029501 - [vdsm] VM disk does not get resized when performing live virtual disk resize on block storage
[vdsm] VM disk does not get resized when performing live virtual disk resize ...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.3.0
x86_64 Unspecified
unspecified Severity urgent
: ---
: 3.3.0
Assigned To: Federico Simoncelli
Aharon Canan
storage
:
Depends On:
Blocks: 600483 3.3snap3
  Show dependency treegraph
 
Reported: 2013-11-12 08:54 EST by Elad
Modified: 2016-02-10 14:46 EST (History)
11 users (show)

See Also:
Fixed In Version: is24
Doc Type: Bug Fix
Doc Text:
After live resizing a virtual disk, the size change was not reflected on the virtual machine. Now, the volume is refreshed to update the volume segments, and to make the new size visible to the QEMU process before live extension.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 11:21:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs (8.29 MB, application/x-gzip)
2013-11-12 08:54 EST, Elad
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 21177 None None None Never
oVirt gerrit 21274 None None None Never

  None (edit)
Description Elad 2013-11-12 08:54:57 EST
Created attachment 822990 [details]
logs

Description of problem:
When I live resize virtual VM disk, I don't see the size change on the guest.
Engine reports that the virtual disk size is the new size, but the actual size remains the same.


Version-Release number of selected component (if applicable):
vdsm-4.13.0-0.7.beta1.el6ev.x86_64

How reproducible:
100%

Steps to Reproduce:
On a block pool 
1. create a VM with disk and install OS (RHEL)
2. edit VM disk and add 2G to the disk while the VM is running and the disk is plugged
3. run lsblk command on guest and check if the disk got extended

Actual results:

lvextend on vdsm:

867330ec-7948-44f5-afbe-919e9ff7b78e::DEBUG::2013-11-12 11:51:26,521::lvm::309::Storage.Misc.excCmd::(cmd) '/usr/bin/sudo -n /sbin/lvm lvextend --config " devices { preferred_names = [\\"^/dev/mapper/\\"] ignore_s
uspended_devices=1 write_cache_state=0 disable_after_error_count=3 obtain_device_list_from_udev=0 filter = [ \'a|/dev/mapper/3514f0c54d5c0000d|\', \'r|.*|\' ] }  global {  locking_type=1  prioritise_write_locks=1
 wait_for_locks=1 }  backup {  retain_min = 50  retain_days = 0 } " --autobackup n --size 9216m 5059994f-9d15-492d-827d-d6be091693e4/c47df525-35c7-4e91-9a4a-14dc219f7aff' (cwd None)

Only when we unplug the disk and plug it again, we will see the disk size change on the guest.


Expected results:
Live disk resize should work

Additional info: logs

notice that the relevant lvextend took place on 2013-11-12 11:51:26,521
Comment 1 Aharon Canan 2013-11-24 12:09:42 EST
verified using is24.1
Comment 2 errata-xmlrpc 2014-01-21 11:21:19 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0040.html

Note You need to log in before you can comment on or make changes to this bug.