Bug 1029505 - Duplicate kernel boot options after anaconda upgrade and creating new boot loader configuration on s390x
Duplicate kernel boot options after anaconda upgrade and creating new boot lo...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.5
s390x Linux
medium Severity medium
: rc
: ---
Assigned To: Samantha N. Bueno
Release Test Team
:
Depends On:
Blocks: 972747
  Show dependency treegraph
 
Reported: 2013-11-12 09:00 EST by Jan Stodola
Modified: 2016-05-10 16:42 EDT (History)
2 users (show)

See Also:
Fixed In Version: anaconda-13.21.241-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-10 16:42:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
zipl.conf before upgrade (425 bytes, text/plain)
2013-11-12 09:00 EST, Jan Stodola
no flags Details
zipl.conf after upgrade (1.00 KB, text/plain)
2013-11-12 09:01 EST, Jan Stodola
no flags Details
program.log (20.87 KB, text/plain)
2013-11-12 09:02 EST, Jan Stodola
no flags Details
storage.log (48.45 KB, text/plain)
2013-11-12 09:03 EST, Jan Stodola
no flags Details

  None (edit)
Description Jan Stodola 2013-11-12 09:00:01 EST
Description of problem:
After anaconda upgrade on s390x and creating new boot loader configuration during the upgrade, some boot options are listed twice in kernel parameters section of zipl.conf (for example rd_NO_LUKS, KEYTABLE=...):

[linux-2.6.32-431.el6.s390x]
        image=/boot/vmlinuz-2.6.32-431.el6.s390x
        ramdisk=/boot/initramfs-2.6.32-431.el6.s390x.img
        parameters="root=/dev/disk/by-path/ccw-0.0.3161-part3 rd_NO_LUKS LANG=en_US.UTF-8 rd_NO_LUKS LANG=en_US.UTF-8 rd_NO_MD  KEYTABLE=us cio_ignore=all,!0.0.0009 SYSFONT=latarcyrheb-sun16 rd_DASD=0.0.3161 rd_NO_LVM rd_NO_DM dasd=0.0.3161  KEYTABLE=us rd_NO_MD crashkernel=auto rd_DASD=0.0.3161 SYSFONT=latarcyrheb-sun16 rd_NO_LVM rd_NO_DM"

Version-Release number of selected component (if applicable):
anaconda-13.21.215-1.el6

How reproducible:
always

Steps to Reproduce:
1. install RHEL-6.4 on s390x
2. start graphical (vnc) installation of RHEL-6.5
3. select "Upgrade an Existing Installation" when asked
4. select "Create new boot loader configuration"
5. zipl configuration screen is displayed with "Kernel Parameters" field pre-filled like this:
"rd_NO_LUKS LANG=en_US.UTF-8 rn_NO_MD KEYTABLE=us cio_ignore=all,!0.0.0009 SYSFONT=latacryheb-sun16 rd_DASD=0.0.3161 rd_NO_LVM rd_NO_DM dasd=0.0.3161"

6. do not make any modification, click Next
7. finish the upgrade and reboot to installed system
8. check /etc/zipl.conf

Actual results:
Duplicate kernel parameters in zipl.conf

Expected results:
Each parameter is listed only once

Additional info:
* system boots correctly with duplicate boot options
* unable to reproduce on x86_64 (there is no zipl configuration screen)
Comment 1 Jan Stodola 2013-11-12 09:00:44 EST
Created attachment 822992 [details]
zipl.conf before upgrade
Comment 2 Jan Stodola 2013-11-12 09:01:12 EST
Created attachment 822993 [details]
zipl.conf after upgrade
Comment 4 Jan Stodola 2013-11-12 09:02:46 EST
Created attachment 822995 [details]
program.log
Comment 5 Jan Stodola 2013-11-12 09:03:21 EST
Created attachment 822996 [details]
storage.log
Comment 7 Samantha N. Bueno 2014-04-02 09:09:09 EDT
This is a low priority with no customer case attached; additionally, it does not block installation or the ability to boot post-install, so I'm deferring to 6.7 planning.
Comment 10 Jan Stodola 2016-02-18 10:20:47 EST
Duplicate boot options are not present any more and any additional parameters added during the upgrade are added to the boot parameters on installed system.

Thanks, moving to VERIFIED
Comment 13 errata-xmlrpc 2016-05-10 16:42:47 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0798.html

Note You need to log in before you can comment on or make changes to this bug.