This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1029526 - Version history: error on viewing deleted asset
Version history: error on viewing deleted asset
Status: CLOSED CURRENTRELEASE
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity medium
: ER6
: 6.0.0
Assigned To: manstis
Zuzana Krejčová
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-12 09:29 EST by Zuzana Krejčová
Modified: 2016-07-31 21:08 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:16:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zuzana Krejčová 2013-11-12 09:29:36 EST
Description of problem:
Each asset has Metadata tab with Version history, containing commits. This can be used to view previous versions of the asset.
If you happen to try that with a commit that deleted the asset, an editor is opened (which is a bit strange in this case), with no content, and an error pop-up appears ('File "" could not be found.').

This is a valid use-case and an issue because:
1. People are curious and will try this, knowing the commit deleted the file, just to see what happens.
2. If the file is deleted via git, not GUI, there might be a commit message that doesn't make it immediately clear and so a user wouldn't know not to view this version.
In both cases, it looks very bad at the very least.


Version-Release number of selected component (if applicable):
BPMS 6.0 ER4


Steps to Reproduce:
1. Create an asset - e.g. a DRL file, fill in some content and save.
2. Delete this asset.
3. Recreate this asset - same type, same name.
4. Go to Metadata tab and Version history, try viewing the (4th) commit/revision that deleted the file.


Actual results:
Opened editor and error pop-up.


Expected results:
No error pop-up - just a message/pop-up informing about the fact that the file is unavailable because this commit deleted the asset. Possibly also no other editor being opened.
Comment 2 Zuzana Krejčová 2014-01-06 11:35:43 EST
Very nice.
Verified with ER7, found a related issue though, see bug 1048974.

Note You need to log in before you can comment on or make changes to this bug.