Bug 1029531 - Watchdog detected hard LOCKUP on cpu 0 - Modules linked in: rndis_host cdc_ether usbnet usb_storage etc.
Watchdog detected hard LOCKUP on cpu 0 - Modules linked in: rndis_host cdc_e...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
i686 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-12 09:38 EST by Piero Finizio
Modified: 2014-01-04 08:45 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-04 08:45:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Piero Finizio 2013-11-12 09:38:12 EST
Description of problem:
Trying to use Android device by android-wired-tether app  to connect via usb and get access to the internet using the wifi connection which is established by the handset, (in other words this app use  RNDIS features to create a virtual Ethernet link), on heavy duty on Second Life 3D virtual world, the notebook freezes.

Version-Release number of selected component (if applicable): kernel 3.11.7-200.fc19.i686


How reproducible: Using the connection with large data transfer.

Steps to Reproduce:
1.Log in Second Life 
2.To go in crowded sim
3.

Actual results:
The large data transfer freezes the notebook

Expected results:To keep the connection

Additional info:

[ 4336.776815] WARNING: CPU: 0 PID: 18130 at kernel/watchdog.c:272 watchdog_overflow_callback+0xac/0xd0()
[ 4336.776815] Watchdog detected hard LOCKUP on cpu 0
[ 4336.776815] Modules linked in:
[ 4336.776815]  rndis_host cdc_ether usbnet usb_storage fuse snd_pcm_oss snd_mixer_oss snd_hda_codec_si3054 iTCO_wdt iTCO_vendor_support snd_hda_codec_realtek snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device snd_pcm sdhci_pci sdhci stkwebcam v4l2_common arc4 videodev coretemp btusb lpc_ich mmc_core microcode r592 memstick media joydev serio_raw iwl3945 iwlegacy snd_page_alloc snd_timer i2c_i801 of_i2c bluetooth mac80211 snd cfg80211 r8169 mii soundcore asus_laptop video sparse_keymap rfkill input_polldev acpi_cpufreq mperf binfmt_misc radeon firewire_ohci i2c_algo_bit firewire_core drm_kms_helper ata_generic ttm pata_acpi drm crc_itu_t i2c_core
[ 4336.776815] CPU: 0 PID: 18130 Comm: cool_vl_viewer- Tainted: G        W    3.11.7-200.fc19.i686 #1
[ 4336.776815] Hardware name: ASUSTeK Computer Inc.  F3JP                /F3JP      , BIOS 209     06/11/2008
[ 4336.776815]  00000000 00000000 eef47cb4 c0978ffe eef47cf4 eef47ce4 c0447ace c0b10f68
[ 4336.776815]  eef47d10 000046d2 c0b1a9d7 00000110 c04c5ffc c04c5ffc c04c5f50 00000032
[ 4336.776815]  f4c0e800 eef47cfc c0447b23 00000009 eef47cf4 c0b10f68 eef47d10 eef47d14
[ 4336.776815] Call Trace:
[ 4336.776815]  [<c0978ffe>] dump_stack+0x41/0x52
[ 4336.776815]  [<c0447ace>] warn_slowpath_common+0x7e/0xa0
[ 4336.776815]  [<c04c5ffc>] ? watchdog_overflow_callback+0xac/0xd0
[ 4336.776815]  [<c04c5ffc>] ? watchdog_overflow_callback+0xac/0xd0
[ 4336.776815]  [<c04c5f50>] ? watchdog_enable_all_cpus.part.2+0x40/0x40
[ 4336.776815]  [<c0447b23>] warn_slowpath_fmt+0x33/0x40
[ 4336.776815]  [<c04c5ffc>] watchdog_overflow_callback+0xac/0xd0
[ 4336.776815]  [<c04fa87d>] __perf_event_overflow+0xad/0x340
[ 4336.776815]  [<c04147e7>] ? x86_perf_event_set_period+0x137/0x230
[ 4336.776815]  [<c04fb0c5>] perf_event_overflow+0x15/0x20
[ 4336.776815]  [<c0414e4b>] x86_pmu_handle_irq+0x14b/0x190
[ 4336.776815]  [<c0408fd8>] ? sched_clock+0x8/0x10
[ 4336.776815]  [<c04750d5>] ? sched_clock_local+0x45/0x140
[ 4336.776815]  [<c0980c2c>] perf_event_nmi_handler+0x2c/0x50
[ 4336.776815]  [<c09802f7>] nmi_handle.isra.2+0x57/0x1a0
[ 4336.776815]  [<c098051a>] do_nmi+0xda/0x3e0
[ 4336.776815]  [<c0471231>] ? ttwu_do_activate.constprop.87+0x51/0x60
[ 4336.776815]  [<c097fa4b>] nmi_stack_correct+0x2f/0x34
[ 4336.776815]  [<f87cd4e6>] ? azx_interrupt+0x46/0x170 [snd_hda_intel]
[ 4336.776815]  [<c04c6a75>] handle_irq_event_percpu+0x35/0x1a0
[ 4336.776815]  [<c04c6c0a>] handle_irq_event+0x2a/0x50
[ 4336.776815]  [<c04c8e86>] handle_edge_irq+0x66/0x100
[ 4336.776815]  [<c0404c46>] handle_irq+0x56/0xe0
[ 4336.776815]  [<c040458c>] do_IRQ+0x3c/0xb0
[ 4336.776815]  [<c0466f00>] ? hrtimer_init+0x130/0x130
[ 4336.776815]  [<c0463cc6>] ? SyS_clock_gettime+0x56/0x90
[ 4336.776815]  [<c0986833>] common_interrupt+0x33/0x38
[ 4336.776815]  [<c0970000>] ? __dcbnl_pg_getcfg.isra.10+0x1a0/0x450
[ 4336.776815] ---[ end trace cb3120fc4970aa4a ]---
Comment 1 Justin M. Forbes 2014-01-03 17:10:28 EST
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 19 kernel bugs.

Fedora 19 has now been rebased to 3.12.6-200.fc19.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 20, and are still experiencing this issue, please change the version to Fedora 20.

If you experience different issues, please open a new bug report for those.
Comment 2 Piero Finizio 2014-01-04 04:27:29 EST
Thank you for the interest.
Just now I am on Fedora 20, kernel 3.12.5-302.fc20.i686 and the connection works without any problem on my Asus F3JP notebook.
Comment 3 Michele Baldessari 2014-01-04 08:45:21 EST
Thanks for the confirmation, Piero.

I am closing this BZ.

Note You need to log in before you can comment on or make changes to this bug.