Bug 1029554 - When I set background pic it goes back to default image for new windows space and when I login
When I set background pic it goes back to default image for new windows space...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: wallpapoz (Show other bugs)
19
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Mamoru TASAKA
Fedora Extras Quality Assurance
: Reopened
: 1034938 1035428 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-12 10:28 EST by Knut J BJuland
Modified: 2013-12-23 22:51 EST (History)
5 users (show)

See Also:
Fixed In Version: cinnamon-session-2.0.5-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-23 22:51:55 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
add cinnamon and mate support (needs testing) (1.74 KB, patch)
2013-11-26 08:23 EST, leigh scott
no flags Details | Diff
add mate support (1.28 KB, patch)
2013-11-26 13:29 EST, leigh scott
no flags Details | Diff
fixed mate patch (2.01 KB, patch)
2013-11-27 13:33 EST, leigh scott
no flags Details | Diff
add cinnamon support (working) (2.09 KB, patch)
2013-12-05 06:10 EST, leigh scott
no flags Details | Diff

  None (edit)
Description Knut J BJuland 2013-11-12 10:28:41 EST
Description of problem:
When I set background pic it goes back to default image for new windows space and when I login

Version-Release number of selected component (if applicable):


How reproducible:
Every time

Steps to Reproduce:
1. change background picture using left click in cinnamon
2. logout or change workspace
3.

Actual results:
Change to default image

Expected results:
background image should stay the same.

Additional info:
Comment 1 leigh scott 2013-11-12 10:41:45 EST
post


rpm -qa cinnamon\* nemo nautilus muffin
Comment 2 Knut J BJuland 2013-11-12 12:33:07 EST
cinnamon-control-center-2.0.5-1.fc19.x86_64
muffin-2.0.3-1.fc19.x86_64
cinnamon-screensaver-2.0.2-1.fc19.x86_64
cinnamon-2.0.6-1.fc19.x86_64
cinnamon-desktop-2.0.2-1.fc19.x86_64
cinnamon-control-center-filesystem-2.0.5-1.fc19.x86_64
cinnamon-session-2.0.1-1.fc19.x86_64
cinnamon-translations-2.0.1-2.fc19.noarch
nautilus-3.8.2-1.fc19.x86_64
cinnamon-settings-daemon-2.0.5-1.fc19.x86_64
nemo-2.0.2-1.fc19.x86_64
Comment 3 leigh scott 2013-11-12 13:55:12 EST
Post

ps aux |grep -e nemo -e nautilus
Comment 4 Knut J BJuland 2013-11-12 15:10:08 EST
[knutjbj@super-knut ~]$ ps aux |grep -e nemo -e nautilus
knutjbj   2432  0.0  0.1 1425200 35444 ?       Sl   Nov10   0:05 /usr/bin/nemo -n
knutjbj   9663  0.0  0.0 112660   944 pts/7    S+   21:08   0:00 grep --color=auto -e nemo -e nautilus
Comment 5 Knut J BJuland 2013-11-14 01:46:07 EST
gsettings list-keys org.cinnamon.background 
mode
slideshow-delay
slideshow-folder
slideshow-recursive

When I change background the key in dconf is not updated? I have reset the dconf database. Could you please send me an update schema to add picture-uri.
Comment 6 Knut J BJuland 2013-11-14 02:09:12 EST
I then monitor org.gnome.desktop.background picture-uri
gsettings monitor org.gnome.desktop.background picture-uri

There is process that reset it the out put is
picture-uri: 'file:///home/knutjbj/.cache/gnome-control-center/backgrounds/81bf463da03c34008eee8eb556b1865ecc710d191bb3a5f774980cdba1c00926'
picture-uri: 'file:///home/knutjbj/.cache/gnome-control-center/backgrounds/81bf463da03c34008eee8eb556b1865ecc710d191bb3a5f774980cdba1c00926'
picture-uri: 'file:///home/knutjbj/.cache/gnome-control-center/backgrounds/81bf463da03c34008eee8eb556b1865ecc710d191bb3a5f774980cdba1c00926'
Comment 7 Knut J BJuland 2013-11-14 02:10:21 EST
I copied my files to .cache/gnome-control-center/backgrounds/81bf463da03c34008eee8eb556b1865ecc710d191bb3a5f774980cdba1c00926, but why do cinnamon store files in gnome-control-center.
Comment 8 leigh scott 2013-11-14 05:24:14 EST
(In reply to Knut J BJuland from comment #5)
> gsettings list-keys org.cinnamon.background 
> mode
> slideshow-delay
> slideshow-folder
> slideshow-recursive
> 
> When I change background the key in dconf is not updated? I have reset the
> dconf database. Could you please send me an update schema to add picture-uri.

org.gnome isn't used by cinnamon, plus your trying to set the wrong key.

gsettings set org.cinnamon.desktop.background picture-uri file:///usr/share/backgrounds/images/default.png
Comment 9 leigh scott 2013-11-14 05:27:57 EST
(In reply to Knut J BJuland from comment #7)
> I copied my files to
> .cache/gnome-control-center/backgrounds/
> 81bf463da03c34008eee8eb556b1865ecc710d191bb3a5f774980cdba1c00926, but why do
> cinnamon store files in gnome-control-center.

Sorry I don't understand the question
Comment 10 Knut J BJuland 2013-11-14 05:44:57 EST
MIght be related https://bugzilla.redhat.com/show_bug.cgi?id=706184. 

I copied my wallpaper to ~/.cache/gnome-control-center/backgrounds/81bf463da03c34008eee8eb556b1865ecc710d191bb3a5f774980cdba1c00926  over the default settings

and ran watch -n0 gsettings set org.gnome.desktop.background picture-options "stretched"
 
to keep wallpaper streaced.
Comment 11 Wolfgang Ulbrich 2013-11-14 05:58:00 EST
(In reply to Knut J BJuland from comment #10)
> MIght be related https://bugzilla.redhat.com/show_bug.cgi?id=706184. 
> 
> I copied my wallpaper to
> ~/.cache/gnome-control-center/backgrounds/
> 81bf463da03c34008eee8eb556b1865ecc710d191bb3a5f774980cdba1c00926  over the
> default settings
> 
> and ran watch -n0 gsettings set org.gnome.desktop.background picture-options
> "stretched"
>  
> to keep wallpaper streaced.

You're using wrong paths!!!
Don't use gnome ones for cinnamon!!!
Cinnamon has theie own gesettings keys!!!
1, Copy the wallpaper to ~/home/pictures/example.jpg
2. do 'gsettings set org.cinnamon.desktop.background picture-uri file:////home/pictures/example.jpg
Comment 12 Knut J BJuland 2013-11-14 06:14:03 EST
When I switch workspace the wall paper get reset. 

gsettings monitor org.cinnamon.desktop.background picture-uri
picture-uri: 'file:///home/knutjbj/.cache/gnome-control-center/backgrounds/81bf463da03c34008eee8eb556b1865ecc710d191bb3a5f774980cdba1c00926'

Why is the background reset each time I switch workspace.
I have these commands in .bashrc

gsettings set org.cinnamon.desktop.background picture-uri "file:////home/knutjbj/Pictures/default.png"
gsettings set org.cinnamon.desktop.background picture-options "stretched"
Comment 13 Wolfgang Ulbrich 2013-11-14 06:25:58 EST
What happens if you clean the cache file?
Comment 14 Knut J BJuland 2013-11-14 06:45:32 EST
removed cache file
gsettings monitor org.cinnamon.desktop.background pictur
picture-uri: 'file:///home/knutjbj/.cache/gnome-control-center/backgrounds/81bf463da03c34008eee8eb556b1865ecc710d191bb3a5f774980cdba1c00926'

it now display default background.
Comment 15 leigh scott 2013-11-14 08:34:44 EST
Remove nautilus and see if you can reproduce the issue.
I don't see this issue on x86_64 on F19/20
Comment 16 Knut J BJuland 2013-11-14 08:51:42 EST
I can still reproduce the issue after I have removed nautilus. Are there any log I should send?
Comment 17 Knut J BJuland 2013-11-14 08:56:07 EST
I have also logout after I removed  nautilus.
Comment 18 Knut J BJuland 2013-11-14 09:48:03 EST
Wallpapzo had been installed. I have now removed it.
Comment 19 Fedora Update System 2013-11-14 09:48:33 EST
cinnamon-session-2.0.5-1.fc19, cinnamon-translations-2.0.2-1.fc19, cinnamon-settings-daemon-2.0.7-1.fc19, muffin-2.0.4-1.fc19, cinnamon-2.0.11-1.fc19, nemo-2.0.5-1.fc19, cinnamon-desktop-2.0.3-1.fc19, nemo-extensions-2.0.0-0.1.gitfd3cc88.fc19, cinnamon-control-center-2.0.7-1.fc19, cinnamon-screensaver-2.0.3-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/FEDORA-2013-21055/cinnamon-session-2.0.5-1.fc19,cinnamon-translations-2.0.2-1.fc19,cinnamon-settings-daemon-2.0.7-1.fc19,muffin-2.0.4-1.fc19,cinnamon-2.0.11-1.fc19,nemo-2.0.5-1.fc19,cinnamon-desktop-2.0.3-1.fc19,nemo-extensions-2.0.0-0.1.gitfd3cc88.fc19,cinnamon-control-center-2.0.7-1.fc19,cinnamon-screensaver-2.0.3-1.fc19
Comment 20 Fedora Update System 2013-11-14 09:50:54 EST
cinnamon-session-2.0.5-1.fc20, cinnamon-translations-2.0.2-1.fc20, cinnamon-settings-daemon-2.0.7-1.fc20, muffin-2.0.4-1.fc20, cinnamon-2.0.11-1.fc20, nemo-2.0.5-1.fc20, cinnamon-desktop-2.0.3-1.fc20, nemo-extensions-2.0.0-0.1.gitfd3cc88.fc20, cinnamon-control-center-2.0.7-1.fc20, cinnamon-screensaver-2.0.3-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/FEDORA-2013-21039/cinnamon-session-2.0.5-1.fc20,cinnamon-translations-2.0.2-1.fc20,cinnamon-settings-daemon-2.0.7-1.fc20,muffin-2.0.4-1.fc20,cinnamon-2.0.11-1.fc20,nemo-2.0.5-1.fc20,cinnamon-desktop-2.0.3-1.fc20,nemo-extensions-2.0.0-0.1.gitfd3cc88.fc20,cinnamon-control-center-2.0.7-1.fc20,cinnamon-screensaver-2.0.3-1.fc20
Comment 21 Knut J BJuland 2013-11-14 09:53:05 EST
Please set to resolved work for me. Wallpapzo had beed installed by a mistake.
Comment 22 Fedora Update System 2013-11-16 02:01:35 EST
cinnamon-session-2.0.5-1.fc20, cinnamon-translations-2.0.2-1.fc20, cinnamon-settings-daemon-2.0.7-1.fc20, muffin-2.0.4-1.fc20, cinnamon-2.0.11-1.fc20, nemo-2.0.5-1.fc20, cinnamon-desktop-2.0.3-1.fc20, nemo-extensions-2.0.0-0.1.gitfd3cc88.fc20, cinnamon-control-center-2.0.7-1.fc20, cinnamon-screensaver-2.0.3-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 23 Fedora Update System 2013-11-19 00:24:05 EST
cinnamon-session-2.0.5-1.fc19, cinnamon-translations-2.0.2-1.fc19, cinnamon-settings-daemon-2.0.7-1.fc19, muffin-2.0.4-1.fc19, cinnamon-2.0.11-1.fc19, nemo-2.0.5-1.fc19, cinnamon-desktop-2.0.3-1.fc19, nemo-extensions-2.0.0-0.1.gitfd3cc88.fc19, cinnamon-control-center-2.0.7-1.fc19, cinnamon-screensaver-2.0.3-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 24 leigh scott 2013-11-24 14:30:11 EST
The have reassigned this to wallpapoz to see if the maintainer can find a work around to the issue.

Cinnamon draws the bg not nemo (nautilus fork), it uses jscript

https://github.com/linuxmint/Cinnamon/commit/5af9c4d77f6f76fc815ec8ca1d2f8fbdaeb6a28a


At the moment I've add a conflicts to the cinnamon package, rdieter advises me it isn't acceptable to do so.
So I propose this as another solution

https://github.com/linuxmint/cinnamon-session/pull/14

Have you got a better idea?
Comment 25 Mamoru TASAKA 2013-11-24 20:44:23 EST
* First of all, currently I cannot test cinnamon, as there is 
  already a conflict. This is really a bad idea, as people using
  cinnamon cannot test other desktop environ, and vice versa.

* Second, I have no idea what to do on wallpapoz, as wallpapoz is the
  software to set and change desktop background, so I guess that
  people having wallpapoz installed are actually expecting so.
  There are some other desktop treaking methods in Fedora, like
  nitrogen or wallpaperd.
  So I think having wallpapoz not-working on cinnamon intentionally
  is against users' expectation.
Comment 26 leigh scott 2013-11-26 07:28:53 EST
(In reply to Mamoru TASAKA from comment #25)
> * First of all, currently I cannot test cinnamon, as there is 
>   already a conflict. This is really a bad idea, as people using
>   cinnamon cannot test other desktop environ, and vice versa.
> 

I will remove the conflict after f20 release when I have added wallpapoz to the blacklist.
You could always downgrade cinnamon to test.

> * Second, I have no idea what to do on wallpapoz, as wallpapoz is the
>   software to set and change desktop background,

You need to add cinnamon support to wallpapoz_system.py to fix this, somrthing like

    elif self.window_manager == "Muffin":
      os.system("gsettings set org.cinnamon.desktop.background picture-uri 'file://" + wallpaper + "'")
      os.system("gsettings set org.cinnamon.desktop.background picture-options " + self.wallpaper_style)

as far detection I don't know



 ## class method to find which desktop environment user uses
  def finding_desktop_environment(self):
    raw_window_id = os.popen('xprop -root _NET_SUPPORTING_WM_CHECK').read()
    window_id = raw_window_id[46:raw_window_id.find("\n")]
    raw_wm_name = os.popen('xprop -id ' + window_id + ' 8s _NET_WM_NAME').read()
    wm_name = raw_wm_name[29:raw_wm_name.rfind('"')]
    # default is Gnome3.
    self.window_manager = 'Gnome3'
    if wm_name=='Xfwm4':
      self.window_manager = 'XFCE4'
    else:
      output = os.popen("gnome-session --version")
      result = output.readlines()
      version = result[0].split()[1].split('.')[0]
      if version == '2':
        self.window_manager = 'Gnome'
      elif version == '3':
        self.window_manager = 'Gnome3'

NET_WM_NAME returns

$ xprop -root _NET_SUPPORTING_WM_CHECK
_NET_SUPPORTING_WM_CHECK(WINDOW): window id # 0x1c0000f


$ xprop -id 0x1c0000f _NET_WM_NAME
_NET_WM_NAME(UTF8_STRING) = "Mutter (Muffin)"


>   so I guess that
>   people having wallpapoz installed are actually expecting so.
>   There are some other desktop treaking methods in Fedora, like
>   nitrogen or wallpaperd.
>   So I think having wallpapoz not-working on cinnamon intentionally
>   is against users' expectation.

I would rather have cinnamon working as expected than wallpapoz.
Comment 27 leigh scott 2013-11-26 08:23:06 EST
Created attachment 829258 [details]
add cinnamon and mate support (needs testing)
Comment 28 leigh scott 2013-11-26 08:26:21 EST
(In reply to leigh scott from comment #27)
> Created attachment 829258 [details]
> add cinnamon and mate support (needs testing)

_NET_WM_NAME may nedd fixing for cinnamon

$ xprop -id 0x1c0000f _NET_WM_NAME
_NET_WM_NAME(UTF8_STRING) = "Mutter (Muffin)"
Comment 29 Wolfgang Ulbrich 2013-11-26 10:40:10 EST
(In reply to leigh scott from comment #27)
> Created attachment 829258 [details]
> add cinnamon and mate support (needs testing)

Thanks Leigh!

@ Mamoru TASAKA
I will test a update or scratch build for mate if you're willing to include the patch.
Comment 30 leigh scott 2013-11-26 13:11:56 EST
*** Bug 1034938 has been marked as a duplicate of this bug. ***
Comment 31 leigh scott 2013-11-26 13:29:31 EST
Created attachment 829439 [details]
add mate support

After testing I don't need cinnamon support due to this commit added to cinnamon-2.0.9

https://github.com/linuxmint/Cinnamon/commit/30aa1b2b472ffb04e2a46660929b686189baa4ce

I have redone the patch to add just mate support
Comment 32 stan 2013-11-26 13:46:18 EST
There must be something wrong with the bugzilla search function.  I did a search on cinnamon before I opened the bug, and the only bug it found was an old one from last year.  In fact, I found that hard to believe, and did the search 3 times and still found only that old one.  :-D
Comment 33 Mamoru TASAKA 2013-11-26 20:43:30 EST
Thanks for all people joining this bug, then:

(In reply to leigh scott from comment #31)
> Created attachment 829439 [details]
> add mate support
> 
> After testing I don't need cinnamon support due to this commit added to
> cinnamon-2.0.9
> 
> https://github.com/linuxmint/Cinnamon/commit/
> 30aa1b2b472ffb04e2a46660929b686189baa4ce
> 
> I have redone the patch to add just mate support

Okay, now I've done scratch builds with adding the patch on comment 31 ,
now available on:

F-21
http://koji.fedoraproject.org/scratch/mtasaka/task_6230654/
F-20
http://koji.fedoraproject.org/scratch/mtasaka/task_6230656/
F-19
http://koji.fedoraproject.org/scratch/mtasaka/task_6230655/

Please try above, thank you.
Comment 34 stan 2013-11-26 23:37:05 EST
I used the noarch package from koji for f-20, and updated wallpapoz.  But when I ran yum update cinnamon, it got the exact same error, except for the new package.
The cinnamon update still conflicts with wallpapoz even with the patched version.
:-(
Comment 35 leigh scott 2013-11-27 00:47:44 EST
(In reply to stan from comment #34)
.
> The cinnamon update still conflicts with wallpapoz even with the patched
> version.
> :-(

Try cinnamon-2.0.14-2

https://koji.fedoraproject.org/koji/packageinfo?packageID=14352
Comment 36 stan 2013-11-27 01:13:03 EST
Yes!  That worked.  So, to be pedantic, the koji version of wallpapoz and the koji version of cinnamon don't conflict on F20.

Thank you both for the fast turnaround.
Comment 37 Wolfgang Ulbrich 2013-11-27 10:51:54 EST
The f19 scratch build crashed in mate during seesion start an generate a abrt alarm.

daemon_wallpapoz:119:<module>:KeyError: 'MATE'

Traceback (most recent call last):
  File "/usr/libexec/daemon_wallpapoz", line 119, in <module>
    style = available_style[window_manager][wallpapozxml.style()]
KeyError: 'MATE'

Local variables in innermost frame:
conf_type: u'workspace'
random: <module 'random' from '/usr/lib64/python2.7/random.pyc'>
number: array('i')
GInitiallyUnowned: <class 'gtk.__main__.GInitiallyUnowned'>
GPollableOutputStream: <class 'gio.__main__.GPollableOutputStream'>
array: <module 'array' from '/usr/lib64/python2.7/lib-dynload/arraymodule.so'>
gtk: <module 'gtk' from '/usr/lib64/python2.7/site-packages/gtk-2.0/gtk/__init__.pyc'>
__package__: None
delay: 1.0
WallpapozSystem: <class wallpapoz_system.WallpapozSystem at 0x267fdb8>
available_style: {'LXDE': {'1': 'stretch', '0': 'center', '3': 'fit', '2': 'fit', '4': 'tile'}, 'XFCE4': {'1': '3', '0': '1', '3': '5', '2': '4', '4': '2'}, 'Gnome': {'1': 'stretched', '0': 'centered', '3': 'zoom', '2': 'scaled', '4': 'wallpaper'}, 'Gnome3': {'1': 'stretched', '0': 'centered', '3': 'zoom', '2': 'scaled', '4': 'wallpaper'}}
__doc__: None
string: <module 'string' from '/usr/lib64/python2.7/string.pyc'>
window_manager: 'MATE'
__builtins__: <module '__builtin__' (built-in)>
__file__: '/usr/libexec/daemon_wallpapoz'
wallpapoz_system: <wallpapoz_system.WallpapozSystem instance at 0x26cffc8>
randomvar: 0
GPollableInputStream: <class 'gio.__main__.GPollableInputStream'>
__name__: '__main__'
sys: <module 'sys' (built-in)>
wallpapozxml: <xml_processing.XMLProcessing instance at 0x25835a8>
AsyncIndex: <class '__main__.AsyncIndex'>
GFileDescriptorBased: <class 'gio.__main__.GFileDescriptorBased'>
threading: <module 'threading' from '/usr/lib64/python2.7/threading.pyc'>
XMLProcessing: <class xml_processing.XMLProcessing at 0x267fe20>
pathname: '/usr/libexec'
time: <module 'time' from '/usr/lib64/python2.7/lib-dynload/timemodule.so'>
worklist: [[u'Umbenennen', u"'/usr/share/backgrounds/default.png'", u'/home/rave/Bilder/Bumblebee.png', u'/home/rave/Bilder/Shortgreenpigg.png', u'/home/rave/Bilder/Wallpapers-room_com___Fast_burn_by_derekprospero_1920x1200.jpg'], [u'Umbenennen', u"'/usr/share/backgrounds/default.png'"], [u'Umbenennen', u"'/usr/share/backgrounds/default.png'"], [u'Umbenennen', u"'/usr/share/backgrounds/default.png'"]]
os: <module 'os' from '/usr/lib64/python2.7/os.pyc'>
Comment 38 leigh scott 2013-11-27 13:33:05 EST
Created attachment 829867 [details]
fixed mate patch

Hi Wolfgang, Can you test this build please?

http://koji.fedoraproject.org/koji/taskinfo?taskID=6233276

Thanks

Leigh
Comment 39 Wolfgang Ulbrich 2013-11-27 16:07:25 EST
(In reply to leigh scott from comment #38)
> Created attachment 829867 [details]
> fixed mate patch
> 
> Hi Wolfgang, Can you test this build please?
> 
> http://koji.fedoraproject.org/koji/taskinfo?taskID=6233276
> 
> Thanks
> 
> Leigh

Cool Leigh, this fixed patch works well, wallpapoz is working now in f20 mate.

Thanks again
Comment 40 Mamoru TASAKA 2013-11-27 19:02:25 EST
(In reply to Wolfgang Ulbrich from comment #39)
> (In reply to leigh scott from comment #38)
> > Created attachment 829867 [details]
> > fixed mate patch
> > 
> > Hi Wolfgang, Can you test this build please?
> > 
> > http://koji.fedoraproject.org/koji/taskinfo?taskID=6233276
> > 
> > Thanks
> > 
> > Leigh
> 
> Cool Leigh, this fixed patch works well, wallpapoz is working now in f20
> mate.
> 
> Thanks again

Thank you all, I will build this and request pushes on bodhi.
Comment 41 Fedora Update System 2013-11-28 03:55:54 EST
wallpapoz-0.6.2-6.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/wallpapoz-0.6.2-6.fc20
Comment 42 Mamoru TASAKA 2013-11-28 03:57:55 EST
*** Bug 1035428 has been marked as a duplicate of this bug. ***
Comment 43 Fedora Update System 2013-11-28 03:59:41 EST
wallpapoz-0.6.2-6.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/wallpapoz-0.6.2-6.fc19
Comment 44 leigh scott 2013-12-05 06:10:23 EST
Created attachment 833094 [details]
add cinnamon support (working)

(In reply to Mamoru TASAKA from comment #40)
> (In reply to Wolfgang Ulbrich from comment #39)
> > (In reply to leigh scott from comment #38)
> > > Created attachment 829867 [details]
> > > fixed mate patch
> > > 
> > > Hi Wolfgang, Can you test this build please?
> > > 
> > > http://koji.fedoraproject.org/koji/taskinfo?taskID=6233276
> > > 
> > > Thanks
> > > 
> > > Leigh
> > 
> > Cool Leigh, this fixed patch works well, wallpapoz is working now in f20
> > mate.
> > 
> > Thanks again
> 
> Thank you all, I will build this and request pushes on bodhi.

Thank you.


I have noticed another issue running wallpapoz on cinnamon, currently wallpapoz tries to start gnome-session.

     else:
      try:
       output = os.popen("gnome-session --version")

To prevent this wallpapoz needs to have cinnamon support added, here's a working patch to add it.
Comment 45 Mamoru TASAKA 2013-12-09 02:58:49 EST
(In reply to leigh scott from comment #44)
> Created attachment 833094 [details]
> add cinnamon support (working)

> I have noticed another issue running wallpapoz on cinnamon, currently
> wallpapoz tries to start gnome-session.
> 
>      else:
>       try:
>        output = os.popen("gnome-session --version")
> 
> To prevent this wallpapoz needs to have cinnamon support added, here's a
> working patch to add it.

Okay, once I will push current testing wallpapoz (otherwise we have to wait another one week), then next I will apply this one.
Comment 46 Fedora Update System 2013-12-10 21:02:31 EST
wallpapoz-0.6.2-6.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 47 Fedora Update System 2013-12-13 01:42:55 EST
wallpapoz-0.6.2-7.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/wallpapoz-0.6.2-7.fc20
Comment 48 Fedora Update System 2013-12-13 01:43:31 EST
wallpapoz-0.6.2-7.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/wallpapoz-0.6.2-7.fc19
Comment 49 Fedora Update System 2013-12-13 22:20:50 EST
wallpapoz-0.6.2-6.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 50 Fedora Update System 2013-12-23 22:39:01 EST
wallpapoz-0.6.2-7.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 51 Fedora Update System 2013-12-23 22:40:22 EST
wallpapoz-0.6.2-7.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 52 Mamoru TASAKA 2013-12-23 22:51:55 EST
Closing this. Thank you, everyone

Note You need to log in before you can comment on or make changes to this bug.