Bug 1029566 - cursor focus out of a dialogue window after "Add and Add Another"
cursor focus out of a dialogue window after "Add and Add Another"
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa (Show other bugs)
7.0
Unspecified Linux
unspecified Severity low
: rc
: 7.0
Assigned To: Martin Kosek
Namita Soman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-12 10:51 EST by Marcel Kolaja
Modified: 2013-11-20 07:22 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-20 07:22:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marcel Kolaja 2013-11-12 10:51:01 EST
Description of problem:
When adding more entities (groups, users,...), a convenient way is offered by hitting Add and Add Another. In such cases, the user is likely to enter all details with keyboard switching between fields with the <TAB> key. That all goes fine for the first entry, when one can switch with using <TAB> to the "Add and Add Another" button. After pressing <Enter> on that button, however, the cursor focus goes out of the dialogue window that appears for adding another entity. The user is required to use the mouse to click on the first field in the dialogue window, which is quite annoying from usability point of view.

Version-Release number of selected component (if applicable):
ipa-server-3.0.0-26.el6_4.4.x86_64

How reproducible:
always

Steps to Reproduce:
1. install IPA server
2. login to the admin WebUI
3. add a group (fill out the required fields) and hit "Add and Add Another"

Actual results:
Cursor focus is out of the dialogue window.

Expected results:
Cursor focus is in the first field of the dialogue window.

Additional info:
none
Comment 2 Martin Kosek 2013-11-12 12:16:39 EST
Looks like a valid request, thanks. I will file an upstream ticket.
Comment 3 Martin Kosek 2013-11-12 12:20:59 EST
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/4025
Comment 5 Martin Kosek 2013-11-20 07:22:14 EST
This report was analyzed by upstream project and was found as already fixed. It is going to be delivered as a part of RHEL-7.0 release.

Note You need to log in before you can comment on or make changes to this bug.