Bug 102957 - Need way to disable animation
Need way to disable animation
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: rhn-applet (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Robin Norwood
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-23 04:56 EDT by Adam Lock
Modified: 2007-04-18 12:57 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-17 17:11:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Lock 2003-08-23 04:56:22 EDT
Description of problem:

The rhn-applet 'throbs' when there are critical updates to be installed. This is
due to some code in rhn_applet.py that creates an anim from the critical icon
with various alpha settings and proceeds to cycle through them on a timer.

There are also some anims for other state transitions.

For performance on low bandwidth connections (e.g. via VNC) there should be a
way to disable these unnecessary animations, e.g. a command line switch.
Comment 1 Michael Lee Yohe 2003-08-25 14:44:10 EDT
Why not disable the applet?  Or, perform the updates necessary to cycle the
applet back to the check mark?
Comment 2 Adam Lock 2003-08-25 16:18:31 EDT
Well I could disable the applet but that would have obvious security implications.

As for performing the suggested updates, sometimes I'm doing something such as
patching the existing kernel source (e.g. with alsa drivers) which means I don't
want to install the latest updates. 

Therefore I'm left with this thing throbbing away in the corner. If there were a
way to disable it, either through a switch. a pref or a menu option I could then
ignore it for the duration of the session.
Comment 3 Robin Norwood 2005-10-08 23:28:40 EDT
The way the applet works right now is, once you've clicked on the 'throbbing'
applet, it reverts to a solid exclamation mark, without animating.  Is this
'good enough', or is there really a use case for having no animation at all?

The code to disable all animation isn't that difficult, I just hate to add 'yet
another option' unless the current behavior is really a problem for some people.

I haven't tried using the applet over VNC, so I guess I don't know what I'm missing.

Note You need to log in before you can comment on or make changes to this bug.