Bug 1029612 - 22HD Touchscreen Incorrectly Controls Both Monitors
22HD Touchscreen Incorrectly Controls Both Monitors
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-settings-daemon (Show other bugs)
7.0
All Linux
unspecified Severity high
: rc
: ---
Assigned To: Rui Matos
Desktop QE
: ZStream
: 1051414 (view as bug list)
Depends On:
Blocks: 1096064
  Show dependency treegraph
 
Reported: 2013-11-12 12:57 EST by Michael Boisvert
Modified: 2017-07-03 11:06 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-03-05 05:59:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Boisvert 2013-11-12 12:57:53 EST
Description of problem:

When using the Cintiq 22HD touch with a dual screen setup, the touchscreen is incorrectly mapped to the entire span of both monitors. It should just be limited to its own display. The stylus is correctly mapped.

How reproducible:

Always

Steps to Reproduce:
1. Install RHEL7.0
2. Create a dual monitor setup (laptop + 22HD)
3. Try using the touchscreen.

Actual results: The touchscreen incorrectly controls the entire span of both monitors.

Expected results: The touchscreen controls its own display regardless of a multi monitor setup.
Comment 1 Peter Hutterer 2013-11-19 03:36:46 EST
verified, this will affect all wacom devices that have the touchscreen on a separate device. Waiting for feedback from the GNOME guys on how this will be addressed, the libwacom change is only one part of the solution and a more generic solution may be sought.
Comment 2 Matthias Clasen 2014-01-21 14:53:33 EST
*** Bug 1051414 has been marked as a duplicate of this bug. ***
Comment 3 Peter Hutterer 2014-01-21 23:43:51 EST
reassigning. this affects all touchscreens including non-wacom ones and should be handled by the desktop environment.
Comment 4 Matthias Clasen 2014-01-31 10:18:54 EST
Carlos is working on a fix for this - currently being tested.
Comment 5 Carlos Garnacho 2014-02-05 14:18:50 EST
The corresponding (growingly generic) upstream bug is https://bugzilla.gnome.org/show_bug.cgi?id=709600

I've attached 3 patches there that fix the issue. As for RHEL suitability, the changes to the wacom module are maybe too intrusive, as this module goes already to great lengths to map pens/erasers correctly, the change to GsdDeviceMapper is perhaps more dubious as brings less benefits.

OTOH touchscreen management in the Xrandr module is certainly broken on quite a few situations, so these changes can only improve things, and these are the changes this bug is interested in.
Comment 46 Simo Sorce 2015-01-05 17:00:51 EST
Btw, I forgot to mention that I tested the package (since first build ...) and it resolves the problem. My wacom is now properly tied to the specified monitor only.
Comment 57 errata-xmlrpc 2015-03-05 05:59:14 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0481.html

Note You need to log in before you can comment on or make changes to this bug.