Bug 1029616 - ValueError: ('invalid size specification', '0.00 MB') - crash after pre-release warning screen in French, Kazakh and possibly other languages
ValueError: ('invalid size specification', '0.00 MB') - crash after pre-relea...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Shea
Fedora Extras Quality Assurance
abrt_hash:951d99e6c2b63ba1cc13e3681f0...
:
: 1029864 1039133 (view as bug list)
Depends On:
Blocks: F20FinalBlocker
  Show dependency treegraph
 
Reported: 2013-11-12 13:16 EST by opus
Modified: 2013-12-07 07:28 EST (History)
15 users (show)

See Also:
Fixed In Version: python-blivet-0.23.7-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-29 08:56:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (257.55 KB, text/plain)
2013-11-12 13:16 EST, opus
no flags Details
File: anaconda.log (4.15 KB, text/plain)
2013-11-12 13:16 EST, opus
no flags Details
File: environ (404 bytes, text/plain)
2013-11-12 13:16 EST, opus
no flags Details
File: lsblk_output (1.89 KB, text/plain)
2013-11-12 13:16 EST, opus
no flags Details
File: nmcli_dev_list (5.41 KB, text/plain)
2013-11-12 13:16 EST, opus
no flags Details
File: os_info (291 bytes, text/plain)
2013-11-12 13:16 EST, opus
no flags Details
File: program.log (30.35 KB, text/plain)
2013-11-12 13:16 EST, opus
no flags Details
File: storage.log (76.33 KB, text/plain)
2013-11-12 13:17 EST, opus
no flags Details
File: syslog (113.65 KB, text/plain)
2013-11-12 13:17 EST, opus
no flags Details
File: ifcfg.log (934 bytes, text/plain)
2013-11-12 13:17 EST, opus
no flags Details
File: packaging.log (11.91 KB, text/plain)
2013-11-12 13:17 EST, opus
no flags Details

  None (edit)
Description opus 2013-11-12 13:16:26 EST
Description of problem:
this bug appear just after graphical warning
********************
this is a beta. set up could damage ....
********************

I don't know what cause the bug unless SSD are not supported

I choose the DVD way since I think it is the best, beside I can use an upgrade via yum

I have a fedora 19 install on this machine

Version-Release number of selected component:
anaconda-20.25.6-1

The following was filed automatically by anaconda:
anaconda 20.25.6-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/size.py", line 100, in _parseSpec
    raise ValueError("invalid size specification", spec)
  File "/usr/lib/python2.7/site-packages/blivet/size.py", line 138, in __new__
    self = Decimal.__new__(cls, value=_parseSpec(spec))
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/lib/space.py", line 74, in check
    free = Size(spec="%.2f MB" % self.storage.fileSystemFreeSpace)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 281, in _updateContinue
    if self._checker and not self._checker.check():
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 276, in _handleCompleteness
    self._updateContinue()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 262, in _updateCompleteness
    self._handleCompleteness(spoke, update_continue)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 213, in _createBox
    self._updateCompleteness(spoke)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 379, in refresh
    self._createBox()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/__init__.py", line 740, in _on_continue_clicked
    nextAction.refresh()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/__init__.py", line 68, in _on_continue_clicked
    cb()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/welcome.py", line 317, in _on_continue_clicked
    StandaloneSpoke._on_continue_clicked(self, cb)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/__init__.py", line 72, in <lambda>
    self.window.connect("continue-clicked", lambda *args: self._on_continue_clicked(cb))
ValueError: ('invalid size specification', '0.00 MB')

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2020-Beta\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.11.6-301.fc20.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        20-Beta
Comment 1 opus 2013-11-12 13:16:31 EST
Created attachment 823070 [details]
File: anaconda-tb
Comment 2 opus 2013-11-12 13:16:35 EST
Created attachment 823071 [details]
File: anaconda.log
Comment 3 opus 2013-11-12 13:16:39 EST
Created attachment 823072 [details]
File: environ
Comment 4 opus 2013-11-12 13:16:44 EST
Created attachment 823073 [details]
File: lsblk_output
Comment 5 opus 2013-11-12 13:16:48 EST
Created attachment 823074 [details]
File: nmcli_dev_list
Comment 6 opus 2013-11-12 13:16:52 EST
Created attachment 823075 [details]
File: os_info
Comment 7 opus 2013-11-12 13:16:55 EST
Created attachment 823076 [details]
File: program.log
Comment 8 opus 2013-11-12 13:17:00 EST
Created attachment 823077 [details]
File: storage.log
Comment 9 opus 2013-11-12 13:17:05 EST
Created attachment 823078 [details]
File: syslog
Comment 10 opus 2013-11-12 13:17:09 EST
Created attachment 823079 [details]
File: ifcfg.log
Comment 11 opus 2013-11-12 13:17:13 EST
Created attachment 823080 [details]
File: packaging.log
Comment 12 opus 2013-11-12 13:32:27 EST
I want to precise that I'm using an USB drive for this installation
Comment 13 opus 2013-11-12 13:50:16 EST
The installer bug when I choose french translations for system. 
I'm currently installing english (UK) version of the système (oss latin9) and it works
Comment 14 opus 2013-11-12 15:37:15 EST
After installation process, I've successfully change keymap / update all packages
Comment 15 Thomas Citharel 2013-11-13 11:04:13 EST
Starting Anaconda, chosing language and go foward, after warning this is a beta version.

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=UUID=BAA3-C2E2 rootfstype=vfat ro rd.live.image quiet rhgb rd.luks=0 rd.md=0 rd.dm=0 BOOT_IMAGE=vmlinuz0 
hashmarkername: anaconda
kernel:         3.11.6-301.fc20.x86_64
other involved packages: python-blivet-0.23.4-1.fc20.noarch
package:        anaconda-20.25.6-1.fc20.x86_64
packaging.log:  
product:        Fedora
reason:         ValueError: ('invalid size specification', '0.00 MB')
release:        Fedora release 20 (Heisenbug)
version:        20
Comment 16 opus 2013-11-13 11:07:20 EST
The install process fail for live cd (for my) but not for install dvd (not live)
Comment 17 Jean-François Fortin Tam 2013-11-14 11:47:19 EST
Started the F20 beta installer, chose French as the language and French Canada as the keyboard layout, then clicked Continue ("Poursuivre") and was hit with this error dialog.

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-Live-Desktop-x86_64-20-Be rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
hashmarkername: anaconda
kernel:         3.11.6-301.fc20.x86_64
other involved packages: python-blivet-0.23.4-1.fc20.noarch
package:        anaconda-20.25.6-1.fc20.x86_64
packaging.log:  
product:        Fedora
reason:         ValueError: ('invalid size specification', '0.00 MB')
release:        Fedora release 20 (Heisenbug)
version:        20
Comment 18 Jean-François Fortin Tam 2013-11-14 11:52:45 EST
Anaconda devs, I think I have pinpointed the root cause for this bug: this only happens if you select a language different than English for the installer - this is not affected by the chosen keyboard layout.

A hunch of mine is that this might have something to do with the various ways locales handle decimals: some use a period (".") and some use a comma (","), among other things.
Comment 19 openfred 2013-11-14 16:03:52 EST
Just use Fedora 20 Beta on a usb stick
Launch Fedora
Connect to Wifi
Launch the installer
Choose French on left column
Leave French(France) on right column
Click next
==> crash !

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-Live-Desktop-x86_64-20-Be rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
hashmarkername: anaconda
kernel:         3.11.6-301.fc20.x86_64
other involved packages: python-blivet-0.23.4-1.fc20.noarch
package:        anaconda-20.25.6-1.fc20.x86_64
packaging.log:  
product:        Fedora
reason:         ValueError: ('invalid size specification', '0.00 MB')
release:        Fedora release 20 (Heisenbug)
version:        20
Comment 20 Gwendal 2013-11-15 17:12:05 EST
Same bug here with a french install attempt.
Comment 21 Adam Williamson 2013-11-19 22:25:11 EST
Kicked off an install to a VM containing a stock install of Mageia 3, using anaconda-20.25.8-1.fc20.x86_64 , in Kazakh (not sure which of those factors is significant). Error popped up immediately after acknowledging the pre-release warning (did not reach hub).

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=20131119-pretc2-x86_64 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
hashmarkername: anaconda
kernel:         3.11.8-300.fc20.x86_64
other involved packages: python-blivet-0.23.5-1.fc20.noarch
package:        anaconda-20.25.8-1.fc20.x86_64
packaging.log:  
product:        Fedora
reason:         ValueError: ('invalid size specification', '0.00 MB')
release:        Fedora release 20 (Heisenbug)
version:        20
Comment 22 Adam Williamson 2013-11-19 22:28:34 EST
OK, as per the other reporters, language seems to be important: if I run the install in English, no crash. Can reproduce the crash in French too.

A showstopper crash in a major language seems like it ought to be a blocker, proposing.
Comment 23 Petr Schindler 2013-11-20 08:44:19 EST
Seems to affect only some subset of languages. Czech language works fine, but I reproduced it with French too.
Comment 24 Jean-François Fortin Tam 2013-11-20 11:34:32 EST
As I said in my comment 18, this may have something to do with the fact that the French locale uses commas instead of dots/periods for decimals, which is certainly not the case for every language. You should probably investigate this avenue if you haven't already.
Comment 25 Adam Williamson 2013-11-20 12:15:08 EST
Discussed at 2013-11-20 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-11-20/f20-blocker-review.2013-11-20-17.00.log.txt . Accepted as a blocker as a conditional violation of criterion "The installer must run when launched normally from the release-blocking images." in at least French and Kazakh, and possibly other languages.
Comment 26 David Shea 2013-11-20 15:34:37 EST
The problem is actually that the size specifier is supposed to be in the current language. A lot of the time the size abbreviations are the same as they are in English and no one notices, but in French "MB" is translated as "MO" (for octets), so our constant "MB" strings don't work.

Posted patches to blivet and anaconda. Here's an updates image against TC1 for anyone who wants to try it out: http://dshea.fedorapeople.org/1029616.img
Comment 27 Adam Williamson 2013-11-20 15:42:01 EST
Makes sense, but as a general approach question, wouldn't it make more sense for the code not to need this stuff to be translated, rather than adding the complexity of translating it and trying to make sure you catch every case that might need to be translated?
Comment 28 David Shea 2013-11-20 16:29:37 EST
(In reply to Adam Williamson from comment #27)
> Makes sense, but as a general approach question, wouldn't it make more sense
> for the code not to need this stuff to be translated, rather than adding the
> complexity of translating it and trying to make sure you catch every case
> that might need to be translated?

Then we would have to translate all the instances where a size string is input by the user, which is most of what this class is used for.
Comment 29 David Shea 2013-11-20 16:45:33 EST
The Kazakh case is related but different-ish: it was hitting the same translation problem as French, but had the more fundamental problem that we failed on non-Latin characters. Updated 1029616.img with a patch for that.
Comment 30 Adam Williamson 2013-11-20 18:46:33 EST
Testing with http://dshea.fedorapeople.org/1029616.img right now - i.e. after dshea thought he'd fixed Kazakh - confirms the fix with French, but not Kazakh: still crashes for me. Error is "ValueError: ('invalid size specification', '0.00 m\xd0\xb1')"
Comment 31 David Shea 2013-11-21 15:13:17 EST
*** Bug 1029864 has been marked as a duplicate of this bug. ***
Comment 32 David Shea 2013-11-21 15:34:34 EST
New patches new updates everybody's a winner step right up

http://dshea.fedorapeople.org/1029616-3.img
Comment 33 David Shea 2013-11-21 15:59:02 EST
The last updates img is for TC2, btw. I didn't add anything from pykickstart like I did last time so it will probably crash on TC1.
Comment 34 dominique 2013-11-22 01:28:23 EST
I am the reporter of bug 1029864 and the bug is still present in the fedora TC2 x86.64 DVD.iso, tested with french and dutch.
Comment 35 Adam Williamson 2013-11-22 01:30:15 EST
That's expected. The fix is not in TC2. If you can test with the updates.img from c#32 and confirm that it fixes the bug, that'd help. thanks!
Comment 36 dominique 2013-11-22 01:33:50 EST
I'm willing to test this patch, but how include this patch in .iso image ?
Comment 37 Adam Williamson 2013-11-22 01:41:30 EST
https://fedoraproject.org/wiki/Anaconda/Updates
Comment 38 dominique 2013-11-22 10:15:07 EST
Thank Adam.

I can test with the updates.img from c#32 and that work, no crash when I choose french language.
I also test with dutch and that work, no crash.
Comment 39 dominique 2013-11-23 01:45:04 EST
Excuse my bad English, in c#38 dutch is for German language.

I also test with Italian, Spanish and Arabic and no crash when I choose those language.
Comment 40 Fedora Update System 2013-11-25 21:35:23 EST
python-blivet-0.23.6-1.fc20, anaconda-20.25.11-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/FEDORA-2013-21928/python-blivet-0.23.6-1.fc20,anaconda-20.25.11-1.fc20
Comment 41 Fedora Update System 2013-11-26 12:57:36 EST
Package python-blivet-0.23.6-1.fc20, anaconda-20.25.11-1.fc20, pykickstart-1.99.48-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-blivet-0.23.6-1.fc20 anaconda-20.25.11-1.fc20 pykickstart-1.99.48-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-21928/pykickstart-1.99.48-1.fc20,python-blivet-0.23.6-1.fc20,anaconda-20.25.11-1.fc20
then log in and leave karma (feedback).
Comment 42 Kamil Páral 2013-11-27 07:52:53 EST
Tested TC3 with English, Czech, French and Kazakh, no crashes at all.
Comment 43 dominique 2013-11-27 13:07:42 EST
(In reply to Kamil Páral from comment #42)
> Tested TC3 with English, Czech, French and Kazakh, no crashes at all.

I also test with TC3, and confirm no crash.
I test with french, german, italian and spanish.

I leave karma to bodhi.

Thanks
Comment 44 Fedora Update System 2013-11-29 08:56:32 EST
python-blivet-0.23.7-1.fc20, anaconda-20.25.12-1.fc20, pykickstart-1.99.48-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 45 Emmanuel Pacaud 2013-12-07 07:28:38 EST
*** Bug 1039133 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.