Bug 1029622 - EAP Modules distribution - Review resources for org.jbpm static module
EAP Modules distribution - Review resources for org.jbpm static module
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Build and Assembly (Show other bugs)
6.0.0
All All
high Severity unspecified
: ER5
: 6.0.0
Assigned To: Roger Martínez
Jiri Svitak
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-12 13:38 EST by Roger Martínez
Modified: 2015-06-01 21:35 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:12:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roger Martínez 2013-11-12 13:38:56 EST
Description of problem:

Resources included in "org.jbpm" static module must be different for bpms and brms distributions.

These issues were reported by Kris via email. 

The pending changes to org.jbpm module definition are:

1.- Remove org.jbpm:jbpmmigration:jar artifact for both bpms/brms.
2.- Remove org.jbpm:jbpm-­simulation:jar artifact for both bpms/brms.
3.- Remove org.jbpm:jbpm-bpmn2-­emfextmodel:jar and org.jbpm:jbpm-workitem:jar for brms.

Version-Release number of selected component (if applicable):
6.1.0, 6.0.0

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Roger Martínez 2013-11-12 14:00:48 EST
In addition, org.jbpm:jbpm-human-task-audit:jar should be included in jbpm core module too.
Comment 4 Roger Martínez 2013-11-12 14:35:40 EST
The only pending point is "Remove org.jbpm:jbpmmigration:jar artifact for both bpms/brms".

By removing it, some errors are displayed when trying to build&deploy a process:

20:58:25,173 WARN [org.drools.core.xml.ExtensibleXmlParser] (http-localhost/127.0.0.1:8080-1) (null: 2, 733): schema_reference.4: Failed to read schema document 'BPMN20.xsd', because 1) could not find the document; 2) the document could not be read; 3) the root element of the document is not <xsd:schema>.
20:58:25,173 ERROR [org.drools.core.xml.ExtensibleXmlParser] (http-localhost/127.0.0.1:8080-1) (null: 2, 733): cvc-elt.1: Cannot find the declaration of element 'bpmn2efinitions'.
20:58:25,176 WARN [org.drools.core.xml.ExtensibleXmlParser] (http-localhost/127.0.0.1:8080-1) (null: 3, 63): schema_reference.4: Failed to read schema document 'BPMN20.xsd', because 1) could not find the document; 2) the document could not be read; 3) the root element of the document is not <xsd:schema>.
20:58:25,177 WARN [org.drools.core.xml.ExtensibleXmlParser] (http-localhost/127.0.0.1:8080-1) (null: 4, 63): schema_reference.4: Failed to read schema document 'BPMN20.xsd', because 1) could not find the document; 2) the document could not be read; 3) the root element of the document is not <xsd:schema>.
20:58:25,179 WARN [org.drools.core.xml.ExtensibleXmlParser] (http-localhost/127.0.0.1:8080-1) (null: 5, 66): schema_reference.4: Failed to read schema document 'BPMN20.xsd', because 1) could not find the document; 2) the document could not be read; 3) the root element of the document is not <xsd:schema>.

It seems that some schema definition files are located in jbpmmigration and required by other core resources.

I will try to move these to another jbpm core artifact and check if jbpmmigration can be removed from core module.
Comment 5 Roger Martínez 2013-11-13 13:13:17 EST
The xsd definitions located in jbpmmigration artifact has been copied into jbpm-bpmn2 artifact, which is located in jbpm core module.

So, the jbpm core module resource jbpmmigration has been removed.

Commits master
==============
https://github.com/droolsjbpm/jbpm/commit/325bd353072df00fb02a77c3157cb4bd73bb181c
https://github.com/droolsjbpm/kie-wb-distributions/commit/7a93d9a22486a85caddea14569dad69371185858 

Commits 6.0.x
=============
https://github.com/droolsjbpm/jbpm/commit/c8b1e21cbd613e6b76eb418b587a0d5477b0bb33
https://github.com/droolsjbpm/kie-wb-distributions/commit/3b7be80cb54fb6e2ea9450975b204894fca0bf51
Comment 6 Jiri Svitak 2013-12-04 07:09:57 EST
This issue describes rather internal organization of modules and their dependencies. This issue doesn't have a direct impact on customers.

ER5 was already released with EAP 6.1.1 module support. Verified.

Note You need to log in before you can comment on or make changes to this bug.