Bug 1029640 - RHEL7 IPA to add DNA Plugin config for dnaRemote support
RHEL7 IPA to add DNA Plugin config for dnaRemote support
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa (Show other bugs)
7.0
Unspecified Unspecified
medium Severity unspecified
: rc
: ---
Assigned To: Pavel Picka
Namita Soman
:
Depends On: 1052754
Blocks: 1211366
  Show dependency treegraph
 
Reported: 2013-11-12 14:29 EST by Scott Poore
Modified: 2016-11-04 01:43 EDT (History)
6 users (show)

See Also:
Fixed In Version: ipa-4.4.0-0.el7.1.alpha1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 01:43:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
evidence (6.17 KB, text/plain)
2016-09-19 07:15 EDT, Pavel Picka
no flags Details

  None (edit)
Description Scott Poore 2013-11-12 14:29:25 EST
Description of problem:

In larger, more complex IPA environments where Replica's are not all interconnected, we are missing some dirsrv dna plugin configurations to allow a directory server to lookup ranges on other servers once exhausted.

Per bug#971111 under comment 7:

https://bugzilla.redhat.com/show_bug.cgi?id=971111#c7

We need IPA servers to support the following:

objectClass: dnaPluginConfig
dnaRemoteBindDN 
dnaRemoteBindCred

objectClass: dnaSharedConfig
dnaRemoteBindMethod  (SIMPLE, SSL, SASL/DIGEST-MD5, or SASL/GSSAPI)
dnaRemoteConnProtocol:  (LDAP, TLS, or SSL)

The 389 Devs can provide more details there.

If we do not have this, we can see problems adding users/groups once the uid/gid range is exhausted.  This allows an IPA server to get a UID/GID from a server with an available range.  Bug #971111 covers the DS side of the fix needed to support this configuration.

Version-Release number of selected component (if applicable):
389-ds-base-1.3.1.6-8.el7.x86_64

How reproducible:
seen often (but not always) in automated testing.


Steps to Reproduce:
1.  setup IPA env m1-m2-m3
2.  add user on m3

Actual results:

ipa: ERROR: Operations error: Allocation of a new value for range cn=posix ids,cn=distributed numeric assignment plugin,cn=plugins,cn=config failed! Unable to proceed.


Expected results:

user successfully added to ipa

Additional info:
Comment 2 Scott Poore 2013-11-12 20:10:25 EST
FYI, a link to the 389 project page covering the DNA Plugin configuration:

http://directory.fedoraproject.org/wiki/DNA_Remote_Server_Settings
Comment 3 Martin Kosek 2013-11-13 06:59:12 EST
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/4026
Comment 5 Martin Kosek 2014-01-16 04:08:18 EST
To manually configure the DNA Plugin remote support, all shared DNA plugin configuration need to be updated:

dn: dnaHostname=ipa.example.com+dnaPortNum=389,cn=posix-ids,cn=dna,cn=ipa,cn=etc,dc=example,dc=com
dnaRemoteConnProtocol: TLS
dnaRemoteBindMethod: SASL/GSSAPI

dnaRemoteBindDN and dnaRemoteBindCred do not need to be configured in the DNA plugin configuration as we are authenticating via GSSAPI and thus do not need there options.

Second step is to authorize the replica that is not a direct replication peer of IPA master to perform the remote DNA call. Replica LDAP service DN needs to be added to nsDS5ReplicaBindDN on the remote IPA master replica configuration (cn=replica,cn=<suffix>,cn=mapping tree,cn=config) so that the IPA master can allow the operation. In order to be able to automate this step, 389-ds-base Bug 1052754 needs to be implemented first.
Comment 7 Martin Kosek 2014-01-17 13:00:40 EST
(In reply to Martin Kosek from comment #5)
> dn:
> dnaHostname=ipa.example.com+dnaPortNum=389,cn=posix-ids,cn=dna,cn=ipa,cn=etc,
> dc=example,dc=com
> dnaRemoteConnProtocol: TLS
> dnaRemoteBindMethod: SASL/GSSAPI

As Simo advised, dnaRemoteConnProtocol can be set to plain "LDAP" as with "SASL/GSSAPI" one gets the encryption for free.
Comment 8 Martin Kosek 2015-07-07 03:50:04 EDT
The ticket was postponed upstream to the next release, see the details in

https://fedorahosted.org/freeipa/ticket/4026#comment:13

The RHEL work will be therefore postponed too. Sorry for the inconvenience.
Comment 10 Mike McCune 2016-03-28 19:07:19 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 12 Pavel Picka 2016-09-19 07:15 EDT
Created attachment 1202450 [details]
evidence

verified 4.4.0-12
Comment 14 errata-xmlrpc 2016-11-04 01:43:45 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html

Note You need to log in before you can comment on or make changes to this bug.