Bug 1029641 - Cannot install devtodo2
Cannot install devtodo2
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: devtodo2 (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Patrick Uiterwijk
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-12 14:36 EST by Maros Zatko
Modified: 2014-01-17 23:23 EST (History)
1 user (show)

See Also:
Fixed In Version: devtodo2-2.1-8.20120711git8dee6.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-17 23:21:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Maros Zatko 2013-11-12 14:36:34 EST
Description of problem:
After relatively not-so-easy update I've tried to (re)install devtodo2 and all I got was:
# yum install devtodo2
Loaded plugins: langpacks, refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package devtodo2.x86_64 0:2.1-5.20120711git8dee6.fc19 will be installed
--> Processing Dependency: libgo.so.3()(64bit) for package: devtodo2-2.1-5.20120711git8dee6.fc19.x86_64
--> Finished Dependency Resolution
Error: Package: devtodo2-2.1-5.20120711git8dee6.fc19.x86_64 (updates)
           Requires: libgo.so.3()(64bit)
           Available: libgo-4.8.1-1.fc19.x86_64 (fedora)
               libgo.so.3()(64bit)
           Installed: libgo-4.8.2-1.fc19.x86_64 (@updates)
              ~libgo.so.4()(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. yum update
2. yum install devtodo2
3. observe an error

Actual results:
devtodo2 does not install

Expected results:
installed & functional devtodo2

Additional info:
Comment 1 Patrick Uiterwijk 2013-11-12 15:22:10 EST
Well, "yum provides libgo.so.3()(64bit)" returns libgo-4.8.1-1.fc19.x86_64 for me, and with that package installed, yum installed devtodo2 happily for me.

But as I am having issues running it after that, I am currently rebuilding (the libgo library was updated in the Fedora release without rebuilding all the packages that depend on it).
Comment 2 Patrick Uiterwijk 2013-11-12 15:27:45 EST
Could you try http://koji.fedoraproject.org/koji/buildinfo?buildID=477959 ?
Comment 3 Maros Zatko 2013-11-13 18:38:42 EST
So I've tried it, it installed successfully but I got another error on launch. I suppose that's for another BZ :)
Comment 4 Patrick Uiterwijk 2013-11-16 11:29:49 EST
Thank you for testing. I will test it myself when I have time, and will come back to it on this bug!
Comment 5 Patrick Uiterwijk 2014-01-09 05:32:12 EST
Okay, looking back into it.

It seems that the error (about no debug info) is because of a bug in gcc-go: http://gcc.gnu.org/bugzilla/show_bug.cgi?id=57194 .

Currently building and testing a fix.
Comment 6 Fedora Update System 2014-01-09 06:01:00 EST
devtodo2-2.1-8.20120711git8dee6.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/devtodo2-2.1-8.20120711git8dee6.fc20
Comment 7 Fedora Update System 2014-01-09 06:01:08 EST
devtodo2-2.1-8.20120711git8dee6.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/devtodo2-2.1-8.20120711git8dee6.fc19
Comment 8 Fedora Update System 2014-01-10 02:58:18 EST
Package devtodo2-2.1-8.20120711git8dee6.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing devtodo2-2.1-8.20120711git8dee6.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-0562/devtodo2-2.1-8.20120711git8dee6.fc20
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2014-01-17 23:21:48 EST
devtodo2-2.1-8.20120711git8dee6.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2014-01-17 23:23:46 EST
devtodo2-2.1-8.20120711git8dee6.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.