Bug 1029660 - YUM dependency resolution error for rhnsd against official spacewalk repository
YUM dependency resolution error for rhnsd against official spacewalk repository
Status: CLOSED NOTABUG
Product: Spacewalk
Classification: Community
Component: Release (Show other bugs)
2.1
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Clifford Perry
Red Hat Satellite QA List
:
Depends On:
Blocks: space27
  Show dependency treegraph
 
Reported: 2013-11-12 16:08 EST by Bryan Schneiders
Modified: 2017-09-28 14:08 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-12 16:21:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryan Schneiders 2013-11-12 16:08:11 EST
Description of problem:

YUM install commands against the official spacewalk repositories fail because "rhnsd" appears to be missing from the repodata.


Version-Release number of selected component (if applicable):

Tested against:

http://yum.spacewalkproject.org/2.0/RHEL/5/x86_64/
http://yum.spacewalkproject.org/2.0/RHEL/6/x86_64/

How reproducible:

Always.

Steps to Reproduce:
1. rpm -Uvh http://yum.spacewalkproject.org/2.0/RHEL/6/x86_64/spacewalk-repo-2.0-3.el6.noarch.rpm

2. yum install rhn-client-tools rhn-check rhn-setup rhnsd m2crypto yum-rhn-plugin

Actual results:

--> Finished Dependency Resolution
Error: Package: rhn-setup-2.0.1-1.el6.noarch (spacewalk)
           Requires: rhnsd
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Expected results:

Successful dependency resolution.

Additional info:

Installation succeeds if all packages are downloaded and installed from a local directory.  Manually reviewing the primary.xml.gz file suggests rhnsd is missing.
Comment 1 Bryan Schneiders 2013-11-12 16:21:08 EST
My mistake.  There was some confusion about the server and client repositories.

Using the 2.0-client repo (which is what I had downloaded manually) works as expected.

http://yum.spacewalkproject.org/2.0-client/RHEL/6/x86_64/spacewalk-client-repo-2.0-3.el6.noarch.rpm
Comment 2 Eric Herget 2017-09-28 14:08:54 EDT
This BZ closed some time during 2.5, 2.6 or 2.7.  Adding to 2.7 tracking bug.

Note You need to log in before you can comment on or make changes to this bug.