Bug 102971 - rpm Segmentation Fault
Summary: rpm Segmentation Fault
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 9
Hardware: athlon
OS: Linux
medium
low
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-08-23 22:59 UTC by Jonathan Desprey
Modified: 2007-04-18 16:57 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-25 17:37:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jonathan Desprey 2003-08-23 22:59:06 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.1; Linux)

Description of problem:
Hello, found a few bugs with similar problems, yet I can't get any solution to work. After I had installed a rpm package, webmin 1.050-1, the installation went okay, but as soon as I tried to install another rpm package (mysql server) it crashed. So then I tried to query to do rpm -qa and it reported the following

[root@localhost rpm]# rpm -qa
ksymoops-2.4.1-1
fortune-mod-1.0-16
pygtk-libglade-0.6.8-3
netscape-communicator-4.78-2
webmin-1.050-1
Segmentation fault
[root@localhost rpm]#

so then I went to the rpm webpage and ran through the hints section to try and rebuild the db using the page listed and when I ran the db verify it came up with this

[root@localhost rpm]# /usr/lib/rpm/rpmdb_verify Packages
db_verify: Page 3359: overflow page of invalid type 0
db_verify: DB->verify: Packages: DB_VERIFY_BAD: Database verification failed
[root@localhost rpm]#

anyway so then I tried the step of backing up my package listings and then do a dump then a load and it "worked", followed by the rpm -qa again

once more

the same error as above.

HELP!!! :)

I'll post a tar backup of my database at

http://24.138.69.109/rpm/

or if there is a utility that will allow me to view the inner workings of my rpmdatabase I could remove the record for webmin, but I dunno

Thanks JD

Version-Release number of selected component (if applicable):
rpm-4.2 kernel 2.4.20

How reproducible:
Always

Steps to Reproduce:
1.rpm -qa
2.
3.
    

Additional info:

Comment 1 Jonathan Desprey 2003-08-23 23:34:53 UTC
D: adding 11 entries to Filemd5s index.
D:  read h#     546 Header sanity check: OK
D:   +++ h#       5 Header sanity check: OK
D: adding "webmin" to Name index.
D: adding 9572 entries to Basenames index.
D: adding "System/Tools" to Group index.
D: adding 4 entries to Requirename index.
D: adding "" to Providename index.
D: adding 573 entries to Dirnames index.
D: adding 4 entries to Requireversion index.
D: adding "" to Provideversion index.
D: adding 1 entries to Installtid index.
D: adding 1 entries to Sigmd5 index.
Segmentation fault
[root@localhost rpm]

forgot here is the error from rpm -vv --rebuilddb

Comment 2 Jeff Johnson 2003-08-25 17:01:49 UTC
Hmmm, you have a screwed up rpmdb, duh.

Looking, maybe I can resurrect, news at 11.

Comment 3 Jeff Johnson 2003-08-25 17:37:21 UTC
Look for rpmdb-102971.tar.gz at ftp://people.redhat.com/jbj
in ~20 minutes.

Install by doing
    cd /var/lib/rpm
    mv Packages Packages-DELETE
    cd ..
    tar xzvf rpmdb-102971.tar.gz
    rpm --rebuilddb -vv

Can you also append any details about how webmin was installed? Thanks.

Comment 4 Jeff Johnson 2003-08-25 17:45:51 UTC
Hmmm, the file is actually rpmdb-102971-FIX.tar.gz, adjust procedure
appropriately.

Comment 5 Jonathan Desprey 2003-08-25 18:29:30 UTC
Thanks it seems to be working well now. As too how the install for webmin went, 
I can't be sure since it was about 2 weeks ago, but there was a 
error/connection failure when I was trying to install webmin remotely over ssh, 
dunno if that could have done it but its my old install of Linux updated and I 
am a newb :)

Thanks again


Note You need to log in before you can comment on or make changes to this bug.